powered by Jive Software

No Response From Server

When I try to create a chat room I get a No response from server error:

No response from server.:

at org.jivesoftware.smackx.muc.MultiUserChat.create(MultiUserChat.java:308)

at com.mike.stuff.chat.ChatController.createChatRoom(ChatController.java:92)

at com.mike.stuff.chat.ChatController.(ChatController.java:83)

Interestingly, the code prior to this attempts to login an agent, if they don’‘t have an account it creates them one, then it logs them in, it then gets a list of rooms using the getHostedRooms static method of MultiUserChat. All of this works fine. When it detects it needs to create a room because the room it needs to join doesn’'t yet exist it receives the no response error when calling the create method of MultiUserChat.

I have tried creating the room manually (no problem creating the room manually) through the web console and then joining the room via code but I get the same error (although on the join method).

I tried extending the server timout value (all the way to 30 seconds) with the SmackConfiguration class but that had no affect (and even if it did I wouldn’‘t like it because at best that is a band-aid as the server should be able to respond within the default 5 seconds or something else is wrong…plus it doesn’'t take the server a long time to respond on the login and createAccount calls.)

Any ideas?

FYI - I worked with Mike, and fixed the problem. He wasn’'t specifying the full name of the conferencing server in the chat room name/URL.

yeah, yeah…can’'t be smart all the time:-)

Hi,

Any chance of posting the before and after strings as I am having almost the same problem as you were?

In my case I am trying to connect to an already created room. When I call join(“nickname”) I can see that it correctly connects to the room as the nickname is added to the list of current occupants, however the call then eventually fails with the “no response” error.

I was hoping that if I saw your corrected string it may help me figure out what I am doing wrong with my room string: “room@conference.hostname”! When I use the same room string in the Exodus client then it seems to work fine, so I’'m really starting to get a little peeved at it. Any help appreciated.

Regards,

Damian.

I would recommend you increase your packet timeout, SmackConfiguration.setPacketReplyTimeout(10000);

Alex