powered by Jive Software

No spacing between menus in Spark 2.5.8

Anyone can give me solution on this.

I downloaded spark source code version 2_5_8 made some changes & compiled using ant then builded the spark into exe.

Everything working fine, expect the menus. There is no spacing between the menus.

Kindly find the image attached herewith.

Source code download link: http://svn.igniterealtime.org/svn/repos/spark/tags/spark_2_5_8/

Thanks

Jassim

It has to do with the JRE you are using. I tried updating the JRE on spark and it does the same thing. HOWEVER It only does that in the skinned mode. if you change to system look and feel for sparl in the preferences the spacing will fix itself

How to change the system look

Whether this problem will get resolved once if i use source code from below link:

http://svn.igniterealtime.org/svn/repos/spark/tags/spark_2_5_8_skin/

In Spark

Spark >> Preferences >> Appearance >> Check the ‘Use System Look And Feel’ Box >> Restart Spark

The setting itself is stored in spark.properties file in the (insert users directory here)/spark/spark.properties

Hi @Ninjatek

Thanks for response

Is there options to enable this " Use System Look And Feel’ Box" by default in source code instead of changing it after install. So that i can build the exe with Use System Look And Feel’ Box enabled

Is there options to enable this " Use System Look And Feel’ Box" by default in source code instead of changing it after install. So that i can build the exe with Use System Look And Feel’ Box enabled

better later then never:

in src/java/org/jivesoftware/sparkimpl/settings/local/LocalPreferences.java file, change the line 543 from ‘return getBoolean(“useSystemLookAndFeel”, false);’ to ‘return getBoolean(“useSystemLookAndFeel”, true);’

work for 2.5.8