"No username was provided or the specified username was not found"

Guys, I am trying to add “Administrator Account” but keep getting “No username was provided or the specified username was not found.”

It seems like this question has been asked frequently in the past, I read almost all threads but still can’t get pass this last step.

I am not specifying any particular ou in the Base DN because I have multiple OUs that have users inside them and want to search them all. Therefore for the Base DN I am using dc=domain,dc=local

For the Administrator DN: I am using domain\openfire. This is an account that I created for this purpose only and it authenticates just fine.

The User Mapping is testing fine as well and so is the group mapping.

When I come to add the “Administrator Account” I used domain\username, username@domain.local and cn=username,cn=users,dc=domain,dc=local. None of them worked.

Please help


I am also having the same problem. Were you able to find a solution? Anyone else have any ideas on this 3 month old post?

It’s been a while and I can’t remember how did we fix it exactly. In fact it was one of my engineers that fixed it, not me. However, what I remember is; during setup, it asks for AD parameter to pole the AD for groups. If you use the default settings, it will pull everything in AD including computers and users. Where I failed was, I changing this parameter to pull AD groups only and that caused the problem.

Just accept the defaults as much as possible when it comes to LDAP config and that should work.

Sorry… can’t give you much more detail, as I said, it’s been a while. Hope this helps.

1 Like

Thank you for your reply. I was able to get it to work by going back into the configuration and instead of choosing {mail} as my name qualifyer (which returned all of the user accounts), I used {sAMAccountName} as my qualifyer (which returned all of the user accounts plus a number of additional objects that I had to filter out later. After using sAMAccountName, I was able to set an administrator very easily. Thanks Khamis!