powered by Jive Software

No Video of the other Participants

Hello,

First, I must say that this is an amazing project and it’s really going to help me and other alot and above all thank you for sharing this solution openly.

I’m not much a technical guy but have managed to install it on an Openfire system which is running on an old Ubuntu, anywayz I installed the Jitsi video bridge plugin and then configured the config.js of ofmeet and jitmeet. I have made the exceptions in the firewall for two ranges 5000-6000 and 50000-60000 and these are done on servers and clients too.

But now when any other client connects, the second BLACK screen adds. I can not even hear the other participant.

Please do let me know where I’m mistaking as I have followed the earlier discussions @Artem Drach(http://community.igniterealtime.org/thread/51805?tstart=0)) as this was the nearest to my issues but even then I couln’t solve the issue.

the jitmeet/config.js:

var config = {

hosts: {

domain: ‘efax.domain.com’,

muc: ‘conference.’, // FIXME: use XEP-0030

bridge: ‘jitsi-videobridge.’ // FIXME: use XEP-0030

},

// useStunTurn: true, // use XEP-0215 to fetch STUN and TURN server

// useIPv6: true, // ipv6 support. use at your own risk

useNicks: false,

bosh: '[http://efax.domain.com:7070/http-bind/](http://efax.domain.com:7070/http-bind/)', // FIXME: use xep-0156 for that

getroomnode: function (path)

{

console.log(‘getroomnode’, path);

var name = “r”;

var roomnode = null;

var results = new RegExp(’[\?&]’ + name + ‘=([^&#]*)’).exec(window.location.href);

if (!results)

roomnode = null;

else roomnode = results[1] || undefined;

if (!roomnode) {

roomnode = Math.random().toString(36).substr(2, 20);

window.history.pushState(‘VideoChat’, 'Room: ’ + roomnode, path + “?r=” + roomnode);

}

return roomnode;

}

};

**The chorme logs are listed below for your reference: **

**
**

Looks like the problem may be in the Jitsi videobridge engine. Have a look at your openfire log files. Not sure what it will be called on Ubuntu, but on windows, you would be looking for stderror.log

Dele,

I got exactly the same issue with ofmeet, and with jitmeet it is the same result…

Got it, Finaly I can see others .

It was a mistake from my side actually there were two jitsi.jar plugin files in the plugin folder which was creating a confusion for the engine and more over the linux geeks can get the logs from /var/log/openfire/error.log this log helped me alot. Use pipe for getting them out as they are too lengthy…

Thank’s Dele for the support and I’m love’n it

Hi,

I’ve got exactly the same problem. But I’m testing this in my local network and server firewall is disabled.

This is the error I get from STDERR:

INFO: ICE processing state of IceUdpTransportManager #68231c67 of channel 2aef02f8ebce3242 of content audio of conference 47db0de43087f22a changed from Waiting to Running.

03 17, 14 7:38:05 AM org.ice4j.ice.ConnectivityCheckClient startChecks

INFO: Start connectivity checks!

SENT: <conference xmlns="http://jitsi.org/protocol/col

ibri" id=“47db0de43087f22a”>81:A7:39:07:CA:5A:8B:9C:67:A8:54:CE:05:E1:DA:8A:08:A4:4B:DE</finge rprint><can$idate component=“1” foundation=“1” generation=“0” id=“47db0de43087f22a511d9ca52aef02f8ebce32426f173e3d05ef74fc5” network=“0” priority=“2130706431” protocol=“udp” type=“host” ip=“0.0.0.0” port=“5032”/><candidate component=“2” foundation="1$ generation=“0” id=“47db0de43087f22a511d9ca52aef02f8ebce32426f173e3d03e963f38” network=“0” priority=“2130706430” protocol=“udp” type=“host” ip=“0.0.0.0” port=“5033”/>

03 17, 14 7:38:11 AM org.ice4j.ice.ConnectivityCheckClient processTimeout

INFO: timeout for pair: 0.0.0.0:5032/udp/host -> 10.0.8.191:35204/udp/host (audio.RTP), failing.

03 17, 14 7:38:11 AM org.ice4j.ice.ConnectivityCheckClient processTimeout

INFO: timeout for pair: 0.0.0.0:5033/udp/host -> 10.0.8.191:41287/udp/host (audio.RTCP), failing.

03 17, 14 7:38:11 AM org.ice4j.ice.ConnectivityCheckClient updateCheckListAndTimerStates

INFO: CheckList will failed in a few seconds if nosucceeded checks come

03 17, 14 7:38:16 AM org.ice4j.ice.ConnectivityCheckClient$1 run

INFO: CheckList for stream audio FAILED

03 17, 14 7:38:16 AM org.ice4j.ice.Agent checkListStatesUpdated

INFO: ICE state is FAILED

03 17, 14 7:38:16 AM org.jitsi.util.Logger info

INFO: ICE processing state of IceUdpTransportManager #68231c67 of channel 2aef02f8ebce3242 of content audio of conference 47db0de43087f22a changed from Running to Failed.

03 17, 14 7:38:16 AM org.jitsi.util.Logger error

SEVERE: Failed to wrapup the connectivity establishment of the TransportManager/transportManager of channel 2aef02f8ebce3242 of content audio of conference 47db0de43087f22a!

net.java.sip.communicator.service.protocol.OperationFailedException: Could not establish connection (ICE failed)

at org.jitsi.videobridge.IceUdpTransportManager.wrapupConnectivityEstablishment(Ic eUdpTransportManager.java:819)

at org.jitsi.videobridge.Channel.runInWrapupConnectivityEstablishmentCommand(Chann el.java:1288)

at org.jitsi.videobridge.Channel.access$600(Channel.java:41)

at org.jitsi.videobridge.Channel$WrapupConnectivityEstablishmentCommand.run(Channe l.java:1893)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

03 17, 14 7:38:42 AM org.jitsi.util.Logger info

INFO: Expired content audio of conference a7edcb891da46629. The total number of conferences is now 3, channels 2.

id=“47db0de43087f22a511d9ca52aef02f8ebce32426f173e3d03e963f38” network=“0” priority=“2130706430” protocol=“udp” type=“host”** ip=“0.0.0.0”** port=“5033”/>

03 17, 14 7:38:11 AM org.ice4j.ice.ConnectivityCheckClient processTimeout

INFO: timeout for pair: **0.0.0.0:5032/udp/host -> 10.0.8.191:35204/udp/host **(audio.RTP), failing.

That does not look right

Hmm… nevermind. Got it working on a clean install on Debian.

The one I tried that gave that error was part of an Elastix install on CentOS.

Thanks anyway