Nohup: appending output to `nohup.out''

I have copied the wildfire start-up script to my init.d directory. Everytihng is working properly but wildfire still outputs to nohup.out. How can I prevent this from happening?

Hi Kati,

this is normal for the provided script. Try “nohup ls &” - it will produce the same message.

If you change this to “nohup ls >ls.log 2>&1 &” the message will no longer appear.


Upd: Added this to JM-872

But is it possible to redirect output to syslog?

And also I looked at my nohup.out file and it is completely empty. Is that normal?

Oh, and I tried to run the command nohup ls >ls.log 2>&1 &; however, it did not work. The message "nohup: appending output to “nohup.out”’’ appreared again whe I tried to restart the server.

Hi Kati,

it makes no sense to send the content of nohup.out to syslog. If you request a javacore (kill -3) it will be written in this file. Wildfire writes it log messages to the log files in wildfire/logs/ and not to standard out or standard error, so this file stays empty.

“nohup ls >ls.log 2>&1 &” itself does not display "nohup: appending output to “nohup.out”’’ while

“nohup ls >ls.log &” does.

So you need to modify the wildfire/bin/wildfire script, and there the line

nohup "$app_java_home/bin/java" -server .... "$@" &


nohup "$app_java_home/bin/java" -server .... "$@" &  >../logs/SDTOUT.log 2>../logs/SDTERR.log

“&” is a “&” but it is displayed wrong because of a well-known forum bug.