powered by Jive Software

Nohup.out big size problem

Nohup.out file grows to the maximum disk capacity (20 GB).
Openfire then stops working and must restart the server to get it working again.

This file grows continuously, until the system stops because there is no disk space.

My solution is to do a task to restart the server every X days.

Can anyone help with this?
Is there any way to clean regularly nohup.out without restarting the server?

Openfire 3.7.1

Centos 6 x86_64

Here are some logs:

Error.log

2013.10.16 09:12:23 org.jivesoftware.openfire.reporting.stats.RrdSqlBackend - Error while updating information in database: java.sql.SQLException: File input/output error: /opt/openfire/embedded-db/openfire.log in statement [UPDATE ofRRDs SET bytes = ?, updatedDate=? WHERE id = ?]

Hello,

We have the same problem with our Openfire deployment. The nohup.out file grows exponentially, almost 3GB per day. But for us it’s not the main problem. We’ve noted that when openfire writes on this not at all times but every 30 to 45 minutes about 1 minutes, writing a bunch of information. During those times the CPU usage grows and affects the performance of openfire.

We’ve tried to adapt the openfire script “/rc.d/init.d” changing the following:

  • su -s /bin/sh -c “nohup $OPENFIRE_RUN_CMD > $OPENFIRE_LOGDIR/nohup.out 2>&1 &” $OPENFIRE_USER

  • su -s /bin/sh -c “nohup $OPENFIRE_RUN_CMD > /dev/null 2>&1 &” $OPENFIRE_USER

It resolves the problem of the nohup.out file, but we don’t know the implications of this solution.

How did you resolve this problem, Lucas?

Thank you

It would be useful to know what is being written over-and-over again to the nohup.out file, so to actually fix the problem.

Hello Daryl,

Thank you for the suggestion. You’re right, we have disabled the debug option of one of the plugins and now the file size is normal.

Thanks for your support.