powered by Jive Software

Non-Admin Windows User

New user to Wildfire and Spark. I’'ve setup wildfire and spark for a small company.

Spark has some issues when run as a non-admin user in Windows. I’'ve encountered the same problem on Windows 2000, XP and 2003 Server (Terminal Services).

Like normal I install spark as an admin. Then when logging in as a non-admin I can start the program fine and login, but when I pull up the Connect - Preferences menu I get the screen but with no icons in the left had side white box and the rest of the dialog box is gray.

This isn’‘t a big problem, but since I can’‘t get to the preferences I can’‘t set things like “start in tray” and “launch on startup”. Also if I check Auto Login I can’'t ever stop it from auto logging in.

I’'m using Spark 1.0.3 Offline Installation

Windows (2000, XP, 2003)

David Steven

This doesn’‘t happen for me. Maybe it’'s an issue on where you allow users with only “user rights” create files and folders. By default, when a new user starts Spark it will create a directory under C:\documents and settings\spark and this is where it stores all settings. Make sure of the security of the base user container in your setups and see if the user can can create and write to the directory. I think this is the case for Win2k and WinXP. Hope that helps somehow.

I had the same issue and resolved it by assigning the user to the Power Users group. For whatever reason, the default permissions in windows just aren’'t quite sufficient.

-Thomas

Unfortunately, I don’‘t want to go the Power User route. I don’‘t want my user’'s installing crap (most of it probably without their knowledge - spyware etc.)

I found another issue as limited/restricted user. You can’'t chat unless you give the user modify rights the the directory where the spark is installed.

I really like the simplicity of this XMPP chat client, and I’'ll be using it for now, but these issues make it harder for me to want to use it larger scale.

At the risk of being rude, can anyone recommend a simple Jabber/XMPP client that works in Windows 2000+ with limited user rights?

Thanks.

Anyway for me to try and repro this on my xp box? I would like to track down and fix this for the 1.1 release.

Thanks,

Derek

After some more research I need to fill in some more details.

I actually installed spark for the first time on XP while running as a limited user. I used the RunAs command (right clicked on the spark installer) to run it as an admin. I haven’‘t fiddled with it much on that box, but as I type this, I don’'t think their were many of the problems I mentioned earlier.

However, this is not the way I normally install software, I normally install as follows, and this is how I installed on Windows 2000 SP4

Log in as an administrator account

Install Spark 1.0.3 offline edition

Log off

Log in as a restricted user account

Run Spark

Doing it this way definately exhbits all the problems above on W2K I’'ve tried it on 7 different machines.

I’‘ll need to uninstall and re-test again for XP using this method. But I’‘m sure I’'ll want to make sure all traces of spark are gone. Besides the program install directory and the users docs and settings spark folder is there other prefs or settings stored anywhere?

But honestly for my current needs, my users are on W2K so that’'s more important than XP.

Searched and found this thread as a consequence of the same issue, researching Spark’'s adequacy (or not) for our terminal services.

Yes, the Runas should give all the same symptoms as classic multi-user under terminal services, for your development debugging of this. It’'d be a good idea to shake this out pretty well, since “fast switching” in XP – common for home users – is pretty much the same kind of issue.

Hi All,

I’'m making the fix for the 1.1 release due out February 7th. You can track the progress of this bug with SPARK-168.

Cheers,

Derek

I’‘ve recently gotten my Wildfire server up and running and I’‘m wanting to use Spark as the client, but I’'m also having problems with non-admin users.

I’‘ve installed Spark 1.1.0 onto a Windows 2000 test machine with administrative rights. Once I logout and login to the workstation with a standard user account and connect to my server via the Spark client (that works fine), I cannot send or receive messages. The window to send a message never comes up, I’'ve tried the standard double-click on the intended recipient and by right-clicking and choosing Start a Chat. The window to send the message just never appears. If I send a chat message to the workstation with non-admin rights the message window never pops up, but the messages are hitting the client (I verified this by using the Debug Window and viewing the raw received packets.)

I’‘ve tried giving the Everyone group write access to the Spark directory and everything in it and that doesn’‘t resolve the problem either. I’'m running the latest Java runtime environment (5.0 Update 6) on this workstation. Any ideas or suggesions would be greatly appreciated.

Jimmy Martin

Hi Jimmy,

do you see the Contacts and Conferences TAB’'s at the bottom of the screen or are they also missing?

LG

Hi Jimmy,

do you see the Contacts and Conferences TAB’'s at the

bottom of the screen or are they also missing?

LG

The Contacts and Conferences tabs are there and seem to respond when I click on them fine.

Thanks!

Jimmy Martin

Could you paste the spark-error.log file contents here for me to take a look at? They will be located in the user.home/Spark/logs directory. I moved any I/O work out of the installation directory and have it just in the user.home/Spark area, so I’'m suprised the error still exists.

Thanks,

Derek

I checked the log and it was completely empty. I’‘ve now observed something interesting related to this. I installed Spark using the administrator account. When I logged in using my test account, I’'ve had the problem where I cannot send or receive messages. I was thinking this could be related to Windows security issues so I added my test user account to the Power Users group and had the same problem. When I added the test user account to the Administrators group, I still had the problem.

I then tried re-installing Spark using the test user account (with administrative rights now) and the problem went away. I then removed administrative rights for my test user account and the problem seems to be resolved. It would appear that something isn’‘t being set globally on install and it’'s only fully configuring for the currently logged in user (at installation.) Could this be related to settings being set for the current user when Spark is installed and not for the machine?

Jimmy Martin

I’'m seeing the exact same thing on Windows 2000. However, Windows XP seems to work perfectly.

However, I was able to work around these issues before in 1.0.3 by granting modify access to the user(s) to the c:\program files\spark directory.

This no longer seems to work with 1.0.4 or 1.1. I’'ve completly un-installed Spark, including deleting the “Documents and Settings\Spark” folders for every user with no luck.

Can I get a copy of Spark 1.0.3 no JRE? I need to re-install this on a machine at work that I was testing 1.0.4 and 1.1 on.

Well, before you move back to 1.0.3, could you help me debug this issue? I’‘m pretty sure that I’‘m not doing any I/O work from within the spark directory, but rather just the users home directory. I’'m a little stumped at this moment, but would really like to figure this one out. Does anyone have any suggestions?

-Derek

I have no problem helping get to the root of this problem. I’'m extremely glad I stumbled upon Wildfire and Spark. I was looking for a open and free IM platform and I found everything I needed here.

But I’'m running this in a business environment and I need to get my one of my users back to a working Spark installation.

I’'d appreciate being able to re-download 1.0.3. I link here would be nice, but you can also send me one in a Private Message.

Thanks.

I’‘m also willing to help figure this one out so please let me know if I can do anything to help locate the source of the problem. I’'m just conducting a test deployment within my company and that is how I stumbled across the issue.

I worked around it for the one user I had deployed that was having problems by granting them admin rights on their system, logging them out and back into Windows (W2K) and then reinstalling under their profile. I then pulled the admin rights and logged them out and back into the workstation again (didn’‘t want to leave any elevated rights floating around.) It worked fine to resolve my user’‘s problem, but it is only one user and I cannot deploy Spark fully until we find a workaround that’'s less invasive or a fix so please let me know what I can do to help.

Thanks!

Jimmy Martin

I think it’‘s worth noting that I am running Spark from a Windows share with 200+ users, almost all of them have regular user rights, and none of them are having any of the problems described above. That would have me think that it’‘s a permission issue that’‘s causing everyone’'s problems.

Caleb, how did you set up your share? Did you just install Spark to the share and then point to the shared drive via the desktop icon? Did you install Spark on every workstation or are you just running it from the share?

I have no reason I can’‘t do something similar so I’'m just trying to find out how to replicate your setup.

Thanks!

Jimmy Martin

Are your workstations XP or 2000?