OF 3.7 LDAP fails after restart

I have installed openfire 3.7 and configured it for LDAP intp AD. During the setup all the testing was sucessful and after the config was complete I was able to log into the Admin Console and to the server from a pidgin client.

After ther service was stopped and restarted when trying to log into the AC I get a Login Failed: and the pidgin client gets an unable to connect. It appears that the LDAP connector that was working broke after the stop and start of the server. In the warn log I am getting Failed admin console login attempt by Username from but nothing else if the other logs stand out…

I have tried a reboot of the entire server? Any suggestioons would be greatly appreciated.

I’m bumping this question instead of starting a new post as I am experiencing the same issue. someone has to know why this is happening, i’ve found several posts asking about similar issues, anyone have any ideas?

are you using file or SQL based configuration?

I had same issue once before, base dn line was cleared from configuration. I added it back in database (we use sql based config) and it start working.

I am actually using the HSQLDB option that was offered during inital setup.

search where is base dn stored and check that it is correct. that the 1st step

(under assumption that no changes was made to ladap, like ou move, group rename/move etc)

I ran into this same issue and was not able to log back into the Admin Console.

The only way I was able to resolve it was to edit the openfire.xml file located in the /Openfire/conf directory. I changed the setup flag from ‘True’ to ‘False’ which kicked off the intial setup again upon launching the Admin Console.

I just kept the same exact settings as before, and even used the exact same Admin user from LDAP. Was able to login right after completing the quick setup as I had been doing previously.

I do not know what caused this to occur. I simply restarted the service and was unable to login.