powered by Jive Software

Offline redirect still opens pop up then redirects

Hoping this is a known issue, and already filed. If so, does someone have a hack to the template to make it just redirect?

Hi,

If I have a workgroup that doesn’t have any agents online or is closed and I click on the link for that workgroup (even though it shows as offline), a popup window appears that says “Sorry we were not able to handle your request. Please try again later.”

Is this not what you are seeing?

thanks,

Scott

Hmm guess I didn’t explain this well enough.

In the offline settings I’ve chosen to use a redirect rather than the pop up that says to leave a message or come back since we’ll have forums as the alternative path for questions not covered in our documentation, not email. So rather than trying to fit that in the pop up, which wouldn’t handle links as elegantly, I chose the redirect option to give people a full page with instructions on where else to get an answer, or when to try back.

Problem is, when you click on the chat image when it’s closed (i.e. no one is around in the workgroup) it still launches the pop up window (nothing in it loads) then closes the window and redirects the page that had the chat image on it. I would guess that the image script is coded to launch the pop up regardless,and then the pop up has the script to redirect.

This is a problem for us since we’re going to be doing support for all ranges of internet users. People equate pop ups with bad things. We don’t need people wondering what the disappearing pop up was doing, and why it was coming from our site. Guaranteed some won’t come back, and some won’t believe that it wasn’t something malicious.

I can confirm the same behavior here. We have a page on our site that we refer people to during off hours, and the popup loads and then disappears.

-Tony

Hi,

I have logged a bug for this and you can view and track it here - http://www.igniterealtime.org/issues/browse/ENT-312

thanks,

Scott