powered by Jive Software

OfMeet 0.9.1, Openfire 4.1.5, Chrome 59 : No video

Hi all,

I have some problem with last version of OFMeet (LAN and WAN access).

I can create a new conference on url “https://:7443/ofmeet/jitsi-meet/” and connect to it.

I can see all participants in chat room and chat with them. But I can’t see their video. Everything is OK on my localhost, i can see my video but not the others.

My configuration and tests :

  • Windows Server 2016, Openfire 4.1.5, OfMeeting 0.9.1

  • AD authentification

  • I create (in AD) a new user called “focus”. I put his password in “Focus Password” field of Openfire Meeting module.

  • Anonymous connections are allowed (Server settings)

  • In “Meeting > Summary”, I never see conferences in array.

  • In “Chatroom” i can see the room. Number of participants never include “focus user”.

Openfire infos events logs :

**2017.07.28 09:37:15 org.jitsi.jicofo.xmpp.FocusComponent - Focus request for room: test10@conference..fr **

2017.07.28 09:37:15 org.jitsi.jicofo.FocusManager - Created new focus for test10@conference..fr@**.fr conferences count: 1 options: **

**channelLastN: -1 **

**enableLipSync: false **

**useRoomAsSharedDocumentName: false **

**startAudioMuted: 9 **

**stereo: false **

**startBitrate: 800 **

**startVideoMuted: 9 **

enforcedBridge: jitsi-videobridge.**.fr **

**openSctp: true **

**disableRtx: true **

2017.07.28 09:37:30 org.jitsi.jicofo.FocusManager - Focus idle timeout for test10@conference..fr

**2017.07.28 09:37:30 org.jitsi.jicofo.FocusManager - Disposed conference for room: test10@conference..fr conference count: 0 **

What is wrong ?

Thanks for help.

Hi,Ben。

Maybe your Media Configuration is Incorrect。

I used to have problems like you before i config it likt this:

Now i can see Conferences in Sunmmary

Unfortunately,the participants still can not see each other.

Here is my logs:

017.07.28 17:22:50 INFO [IceUdpTransportManager connect thread]: org.jitsi.impl.neomedia.MediaStreamImpl - video codec/freq: null/null Hz
2017.07.28 17:22:50 INFO [IceUdpTransportManager connect thread]: org.jitsi.impl.neomedia.MediaStreamImpl - video remote IP/port: 192.168.0.122/49677
2017.07.28 17:22:50 INFO [IceUdpTransportManager connect thread]: org.jitsi.videobridge.Channel - CAT=stat transport_connected,conf_id=88858473616c937e,content=data,ch_id=6b515c6b5c94b7b e,endp_id=fx4xtvwl
2017.07.28 17:22:50 ERROR [org.jitsi.videobridge.SctpConnection-pool-37-thread-17]: net.java.sip.communicator.util.UtilActivator - An uncaught exception occurred in thread=Thread[org.jitsi.videobridge.SctpConnection-pool-37-thread-17,5,main] and message was: Could not initialize class org.jitsi.sctp4j.Sctp
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.sctp4j.Sctp
at org.jitsi.videobridge.SctpConnection$1.run(SctpConnection.java:476)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:748)
2017.07.28 17:22:53 INFO [TerminationThread]: org.ice4j.ice.Agent - ICE state changed from Completed to Terminated. Local ufrag 64ldt1bm482r63
2017.07.28 17:22:53 INFO [TerminationThread]: org.jitsi.videobridge.IceUdpTransportManager - CAT=stat ice_state_change,conf_id=88858473616c937e,content=data,ch_id=6b515c6b5c94b7be,e ndp_id=fx4xtvwl old_state=Completed,new_state=Terminated
2017.07.28 17:22:53 WARN [EndpointConnectionStatusMonitoring]: org.jitsi.videobridge.EndpointMessageTransport - SCTP connection with zj1cm2yv not ready yet.
2017.07.28 17:22:53 WARN [EndpointConnectionStatusMonitoring]: org.jitsi.videobridge.EndpointMessageTransport - No available transport channel, can’t send a message
2017.07.28 17:22:53 WARN [EndpointConnectionStatusMonitoring]: org.jitsi.videobridge.EndpointMessageTransport - SCTP connection with fx4xtvwl not ready yet.
2017.07.28 17:22:53 WARN [EndpointConnectionStatusMonitoring]: org.jitsi.videobridge.EndpointMessageTransport - No available transport channel, can’t send a message
2017.07.28 17:22:59 WARN [EndpointConnectionStatusMonitoring]: org.jitsi.videobridge.EndpointMessageTransport - SCTP connection with zj1cm2yv not ready yet.
2017.07.28 17:22:59 WARN [EndpointConnectionStatusMonitoring]: org.jitsi.videobridge.EndpointMessageTransport - No available transport channel, can’t send a message
2017.07.28 17:22:59 WARN [EndpointConnectionStatusMonitoring]: org.jitsi.videobridge.EndpointMessageTransport - SCTP connection with fx4xtvwl not ready yet.
2017.07.28 17:22:59 WARN [EndpointConnectionStatusMonitoring]: org.jitsi.videobridge.EndpointMessageTransport - No available transport channel, can’t send a message

Hi Tom,

Local IP adress and Public IP adress are already set

I found more informations :

When i create a new meet, i have this error in errors logs file :

**2017.07.28 12:03:21 org.jitsi.impl.protocol.xmpp.XmppProtocolProvider - Failed to connect/login: No response from the server. **

**No response from the server.: **

**at org.jivesoftware.smack.NonSASLAuthentication.authenticate(NonSASLAuthentication .java:73) **

**at org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java: 367) **

**at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208) **

**at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvide r.java:224) **

**at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvid er.java:47) **

**at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.j ava:192) **

**at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.j ava:187) **

**at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193) **

**at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) **

**at java.util.concurrent.FutureTask.run(Unknown Source) **

**at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201 (Unknown Source) **

**at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source) **

**at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) **

**at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) **

**at java.lang.Thread.run(Unknown Source) **

**2017.07.28 12:03:24 org.jivesoftware.openfire.ldap.LdapGroupProvider - Could not find user in LDAP 70oiiuufn2 **

**2017.07.28 12:03:40 org.jitsi.jicofo.JitsiMeetConferenceImpl - Chat room already left! **

**2017.07.28 12:03:41 org.jitsi.impl.protocol.xmpp.XmppProtocolProvider - Failed to connect/login: No response from the server. **

**No response from the server.: **

Openfire / OFMeet try to found an unknown user (70oiiuufn2 but the name is random) in AD.

If i take a look in Chrome console, i can found this “user” in traces :

[modules/xmpp/xmpp.js] <t.value>: My Jabber ID: 70oiiuufn2@.fr/70oiiuufn2