OfMeet no video and audio of other participant

I installed Ofmeet on my server. When I have two people join the same room. It shows the person joining the room, and I can use the text chat and even the share document and share editing, but the participants can’t see each other. There is no video or audio. I really want to get this work, it seems like an amazing software and I’m really excited to making it all work and showing it to my group.

Here’s my setup

-Windows 2012R2 server on a Azure VM with a public DNS.

-Openfire 3.10.0 Openfire Meeting ver. 0.1.4 Plugin

ports open: tcp 5222,5223,5269,7070,7443,7777 udp 7443

5000-6000 tcp/udp, 50000-6000 tcp/udp

set config.js

hosts: {

domain: hostname, have also tried hostname.com

    muc: 'conference.hostname', // FIXME: use XEP-0030 have also tried conference.hostname.com

bridge: ‘ofmeet-jitsi-videobridge.hostname.com’, // FIXME: use XEP-0030 have also tried jitsi-videobridge.hostname.com or jitsi-videobridge.hostname


bosh: ‘https://hostname.com:7443/http-bind/’, // FIXME: use xep-0156 for that have also tried https://hostname:7443/http-bind

clientNode: ‘https://jitsi.org/jitsimeet’ not sure what this does…could this have anything to do with it?

I posted logs. After many tries, error in log 2 doesn’t always happen, error in Log 1 and 3 always happens. I have been lurking around the site for a few days to find an answer, can’t seem to fix the problem. Going insane Dele and Jay I summon theeee for help!! or anyone would really appreciate it!!!
log3.txt.zip (574 Bytes)
log2.txt.zip (1484 Bytes)
log1.txt.zip (950 Bytes)