OfMeet with Turn Server

Hi, I’m a noob. How do I pass turn/sturn server credentials ofmeet. I put the credentials in the meeting session of admin page under ice servers, but ofmeet doesn’t seem to get any of the changes. I’d appreciate the help.

Thanks in advance!!


Sorry I accidentally clicked the button and now saids question is assumed answered.

make sure it is in JSON notation as required by webrtc

for example : { ‘iceServers’: [{ ‘url’: ‘stun:stun.l.google.com:19302’ }] }

Yea I had exactly what you put down.

I believe the lines “Have we encountered any …? false” checks for the ice candidates right?

The statement “Have we encountered any relay canidates?” is true when I try out jitsi.meet at the Jitsi site.

I created this post a while ago, I believe participants can’t see other is due to NAT traversal and requires me to have a Turn Server. OfMeet no video and audio of other participant It maybe not be the reason. The other post contains log files that you can check out. We are running a study soon and this seems like the perfect platform for us to use. I would really love it if you can help me get this to work. Otherwise I have to go for something commercial. I really appreciate the work you done, this is amazing. Thanks.


That is the setting for a STUN server. To use a TURN server, you have to get access to one or set one up yourself as Openfire Meetings does not have one. You can then use a settings string like this

{ ‘iceServers’: [{ ‘url’: ‘stun:stun.l.google.com:19302’ }, {urls: 'turn:yourip:port', credential: 'password',username: 'username'}] }

I am not a network expert, but maybe the problem is with Azure. If your openfire is not directly on the internet with a static public IP address, then make sure you specify the public and private IP addresses in ofmeet admin settings web page