powered by Jive Software

ofMessageArchive table missing

OK, installed MSSQL 2019 Express, Created database called Openfire, ran MSSQL script from install directory. Worked through installing openfire 4.6 and did run into problems with trying to use windows authentication during setup. So in the middle of the setup I created an SQL user using SQL authentication and that seemed to let me get based the database install screen, so thought things were going pretty good.
Well finished AD integrations, etc… got things up and running, Installed a few plugin’s, and when I installed the Monitoring plugin (archive) all thing seemed to go OK there.
But, i have no messages being saved (can’t search and find any).
When I look at the logs it complains that the ofMessageArchive table is not in the database. Sure enough looking at the database it is not there.

So, where do I go from here to get message archiving to work. I’ve got everything else pretty much working

FYI, new Windows server installation.
I did some digging and found a monitoring_sqlserver.sql file on our old 3.10.2 server we have running.
I ran this on the new server and it created the tables with only one error saying it could not basically change the version number. the old script had at 2 and the value in the table now is 6.
So, I’m figuring there have been some database changes that is keeping it from working.
Now it is inserting some “parts” of the records in the database. I can search and it shows that it recorded converstations, but it doesn’t record the actual message “body” of text. Getting closer

Ok, started with a brand new clean windows server, installed MSSQL Express. Created blank database openfire, Got openfre_sqlserver.sql from openfire\resources folder and run it to create tables.
Got monitoring_sqlserver.sql from plugins\monitoring\database folder and run it to create tables for monitoring plugin. Ran through openfire setup with no problems.
Added plugins…Broadcast, Cllent Control, Monitoring Service, and Subscription
Configured Client control how we wanted, and on Monitoring Service (Archiving) check one-to-one chats, Group chants, stanzas for group chats and saved.
Setup groups, and used my client - spark(2.71) and another test machine and logged in.

It seemed to save the initial conversation between me and the test machine, but I don’t see any further communication. So why would I not see further communication saved?

Well, I don’t know if what I’m seeing is right or not.
It actually is recording the whole conversation, but it is just not showing it in Search results right pane.
If I click view PDF it shows the whole conversation in the PDF.
On our old server (3.10.2) it shows the whole conversation in the right pane