Old story -- GTalk

Ok, I have read the threads, posted to some of them and followed all directions completely.

WIldfire 3.0.0


working well inside WAN

has intenal address Nat’‘s to a public IP which is attached to it’'s REAL name.

Pingable from outside, 5269 open directed to inside server address

Already have one Jabberd2 server dialbacked to WIldfire on port 15269 (has always just worked)

SRV records in place and dig/host - able

white list entries

my other jabberd2 server 15269

gmail.com 5269

no direct client connect from world (5222,5223)

I get connect to gtalk, gtalk talks to me initially

when I pass the dailback hash, it says it got it, but connection times out waiting on GMail to send it back.

adding user on gtalk fails, adding one of my users from gtalk fails.

No server to server TLS or SSL, all dialback… What am I missing??? Is this Firewall redirect causing?


From outside your firewall can you telnet to port 5269?

Have you tried Ehtereal/Wireshark on your Wildfire machine to see what’'s going on on the network?

Nope, haven;t tried ethereal, but will get an authorit to do so. This is a Corp WAN environment, not a home LAN. Can’'t touch 5269 from anywhere else except for google. it is setup like that on the f/w. will see if I can get that port completely opened to any connections. Just a really strange thing…

Ok. the network guys have ‘‘opened’’ port 5269, but I cannot telnet to that port on the server. Would the redirect at the FW from the public ip, tothe internal IP have anythign to do with this???


it seems that your network guys didn’'t add the NAT information @“the network guys have ‘‘opened’’ port 5269, but I cannot telnet to that port on the server.”.



This is what we found out. first the network fw was not allowing connections correctly. we got that ironed out, and the other issue that that there is a fifth server at google. It would seem that there is a server on the 72. A network that was attempting to pass the hash back. that is the server that was NOTin the fw rules and thus it was failing.

With that knowledge, we have now fixed the issue, and can now connect to accounts with Google.

Next up, Voice!

Thanks for the help guys.