powered by Jive Software

One fix for HTTP ERROR 400 Bad Request

I have been trying to get candy to work with my new debian server. I have installed openfire and I have set it up so I am able to connect to it with Spark.

If you are like me and have been slaving away for a couple days trying to figure how to resolve the infamous error below, you can try what solved it for me.


HTTP ERROR 400

Problem accessing /http-bind/. Reason:

Bad Request

Powered by Jetty://


This is not telling you that http-bind doesn’t work, it is just telling you that http-bind did not get a real request like a visit from http://example:7070/http-bind/

Your .htaccess files look more or less like:

Options +FollowSymLinks

RewriteEngine On

RewriteRule http-bind/ http://localhost:7070/http-bind/ [P]

The [P] on the end tells you that it is a proxy redirect. This is necessary for the http-bind to work.

Normal redirects, either R or L will not work with http-bind.

The simple action I had to do was to enable proxy mods for my apache installation.

(If you are running apache2 under debian as I am, “sudo a2enmod” and entering “proxy*” when asked which mods to enable, followed by a “/usr/sbin/apache2ctl restart” fixed it for me, take notice, your apache2ctl file might be located somewhere else.)

(Made this account for this post to try and help someone, I won’t return, sorry)