powered by Jive Software

Online Users not listed in client

I’ve just installed OpenFire version 4.7.3 windows version on a Windows 2019 server. Everything there seems to be running great, linked to ldap successfully. I’ve installed the Spark 2.9.4 client 2 Windows 10 laptops. Spark logins successfully to OpenFire and show on the server as being online for both clients, with 2 different user names. I can send messages back and forth successfully from both clients. However the green dot in both clients for the users I’m messaging back and forth with is grey instead of green. Both users are showing offline to each other in both clients, even though they are logged in and messaging each other, and their personal client status is set to “Online”. Has anyone seen this before? Is there a setting somewhere on the server I’m missing?

Hi. Do users see each other in the user list?

No they do not. That is the whole problem. The messaging back and forth works if you search for a person, but none of the users appear in the list. That is the problem I’m trying to solve.

You either have to add users to each other in the contact list, or create a group on the server and add your users there.

My configuration is connected to ldap, where the groups already exist.

I got you.
Send me the logs.

Thank you. When I go to “View Logs” in the client it says “no error logs found.” The log from the server is attached.
openfire.log (5.4 MB)

Although Spark says that there are no logs, this is not true. This bug has been fixed in nightly builds.
You can find the Spark logs here:
where Plyha - write your name account :smiley:
or %appdata%\spark\logs

Oh ok. Thank you. There IS a log in that location and the contents of that log are the following:

Sep 28, 2022 12:35:33 PM org.jivesoftware.smack.util.DNSUtil resolveDomain
INFO: Could not resolve DNS SRV resource records for _xmpp-client._tcp.(the fqdn of our server). Consider adding those.
Security framework of XStream not initialized, XStream is probably vulnerable.

So it seems to be a DNS issue that’s causing the problem? We have a DNS entry for the spark server that is accurate. Do we need one with a prefix of _xmpp-client._tcip??

Oh wait. The DNS entry for that server is just a HOST A record. We need to add an SRV record. Maybe that will fix the problem. The service would be _ldap?

I don’t think it’s a matter of DNS) Send me the whole log file, you can send me a private message.

I’m still stuck on this if anyone has any ideas.

Sounds like you would like to create a roster group using your ldap groups. Basically you’ll go to Users/Groups the select the Group tab. Next select the group in the list that you want to create the roster for. This will bring up the Edit Group page. Under Contact List (roster) Sharing, you’ll enable the contact list group sharing. You can then create a display name for the group and select who sees the group.