Online users shown as Offline in Spark

  1. Got my openfire 3.7.0 running in Ubuntu 10.10 - Clients with Spark 2.6.2 and Pidgin 2.7.3 Problem: users log in, but all other users are shown as offline. But I can see them on the server as online. When I make new users with local account (no JID), organize them in a Group then it’s ok.

  2. On Spark I only can use Drag&Drop for file transfer on Windows. On Linux it doesn’t work.

need errorlogs

Menu -> Help -> Show logs

but dont post them in here,

you can use for that, and only put the link here

thanks for your immediate answer

thats the error log from my Spark 2.6.2 client on a windows-XP machine in LAN:

and here the error-log from Spark 2.6.2 on Ubuntu - same machine where openfire is running:

when I added local accounts accounts on openfire (e.g. user1@linux-2) and put them in a group called Friends, then it works fine on LAN.

2 years ago,I had openfire (maybe 6.4…?) running on DSuse-Linux with Spark clients (maybe 2.5.x) with Red-5 plugin. It was perfect with audio/video.

Now there is no Red-5 working, nor the new Redfire-plugin.

What happened ? What changed ?

looks like the red5plugin is causing this, try disabling it and see how spark behaves

as for the plugin, i dont know what changed

but it looks like the plugin needs to be updated

now I tried without red-5 plugin. The same behavior.

But I found out that this strange thing did not happen, when I typed in the ‘server’ field th local IP or host-name ( or linux-home). It happens when I type the JID of the server as: ‘’ (I got a DNS-name. And it happens too, when I type the Internet-IP like

Then all users are online in the openfire admin-console. But they are shown as offline in Spark machines on the LAN.

At the same time I got a message in openfire warn.log:

2011.07.02 15:14:14 Error trying to connect to remote server: lookup: connect timed out

at Method)






Shame on me…

Think it is solved. I tried to delete Red5 plugin as Wolf_P. said. But I only deleted in the plugins directory without deactivating it in Spark. After doing so Spark works fine.

But noe I unstalled the new redfire-plugin. With the redfire.war in openfire. But they are not shown in Spark. And this time I did activate :slight_smile:

So, I try to solve; maybe I fail. Then I will ask for help.

But have a lot of thanks for the Tip, Wolf_P.