powered by Jive Software

Open Fire using dyndns.org

I have installed a fresh copy of Open Fire on my Windows Server 2003 machines and it all works fine over the local network. I am now trying to get it to work publicly using the dynamic dns address I set up. That address is in the format myserver.dyndns.org

I can ping myserver.dyndns.org and it replies with the correct ip. I have also opened port 5222 on my firewall via the built in NAT option and have set it to forward that port to the server local IP address. I have tested if the port is open from some online tools and it is. I have also set up server name to be myserver.dyndns.org as recommended but still no joy - the spark client does not see the server when going connecting via myserver.dyndns.org.

Is there something I am forgetting to do?

Hi,

your setup seems to be fine.

Does “telnet myserver.dyndns.org 5222” works while Spark fails to connect? You should see an error in Spark’'s error log file.

Did you configure some special things within Spark using the “advanced” options?

LG

I tried to do a telnet and got the following message:

telnet: connect to address : Connection refused

telnet: Unable to connect to remote host

When trying to connect with Spark I get the following message:

Can’'t connect to server: invalid name or server not reachable

My guess is that your port forwarding is incorrectly set up (wrong IP?)

Hi,

does it work when someone else tries to connect over the internet?

It may be possible that your router / NAT engine has some problems in forwarding internal requests to myserver.dyndns.org:5222 to your server’‘s IP address. So you could configure within your local client hosts file that your server’‘s IP address is myserver.dyndns.org. So you’'ll connect directly to Openfire without reaching your router.

LG

I had someone try to connect from outside my network but it was still not connecting via Spark. However when they did a telnet to my ip and port 5222 it connected. Seems that my firewall is open for that port but not talking to OpenFire properly.