powered by Jive Software

Open Sip Account

I have been wondering if maybe my sip account is not compatible with red5phone, so here you go. I am putting up my sip account so anyone who has a working red5 standalone / openfire + red5plugin install to test if its working for them.

Please be kind enough to privde me with your feedback.

UID : 777010465728
PWD: 0xzwuv

SIP server: 84.45.70.8 (International calling enabled) Not much funds to freak out about.

Thanx in advance.

1 Like

hi

i tested your account and managed to register with red5 openfire plugin.

i called my phone and the call arrived, but when i answer no voice. I need to check as it might be our firewall that block it.

what is the service/proxy you are using?

Lior

so you use open ser with porta billing

signaling work ok with red5 phone voice is depand on your network NAT,firewall, pstn GW…

its can work for you.

Lior

I dont think its the firewall.

The SIP service is on Sip Express. Thanx for testing it, I am in the same situation.

I used a free trial account from voipstunt.com and tested it, the voice was perfect, so firewall can be ruled out.

One observation from another friend, he said that the call was not following DTMF / RFC standards. I dont know how to check that, are you aware of this?

I used wireshark which provided me more evidence that is completely weird, It played back the captured stream. I was able to hear my voice on the number that I called (my mobile) which I never heard on Red5, there was no audio stream captured from my computer to the sip server.

I checked further and the error I found was “Destination Port Unreachable”, I dont know how to fix this and I dont know how it worked with voipstunt and not my SIP server. This is totally flipping my head .

I hope this works out for me, I would definatly post my ordeal so it can help others.

Luke

Really???

Wow you figured out a lot of stuff about my SIP setup. Great!

Let me know what else I need to do to make this work. One more thing, do I have to stick with Openfire or can it be done with Red5 + Red5phone ?

Thank you.

Luke

Hi

I think there is nothing to do with dtmf standard as we are talking regular voice call. I understand if you need to send some dtmf to some ivr system and it would not get it. in your situation I did not mange to get RTP stream at all (no voice on both direction) while when i use from same red5 my own proxy its work like a charme

on my second try i could not complete the call as its replay on the end with 603 decline (maybe you have no more credit on voipstuns).

the voice is not going directlly from your pc to the sip server - its go from your flash player to your red5 server and from there it translated to g711 and send to the other participant. you need to check the signaling and media between your Red5 server to your sip server/service.

Lior

Your proxy!

So are you bridging Red5phone ->yourproxy -> my Sip ser ?

If so, which proxy is it?

If I can set this up on another server which is in the same network as my current SIP server, I believe the “Destination Unreachable” error should be eliminated right !

I will get the account recharged if you would like to test further.

Thank you so much.

Luke

I used my red5 openfire windows server to connect directly to the ip you provided NOT via my proxy.

i can not test much more your problem as I don’t have the time.

but maybe the following info will help you:

  1. consider red5 server as sip ua to your server (like X-lite), if you mange to get registered and get the call in and out signaling is working correctlly for you.

  2. if problem is just with voice check in SDP where you send or get voice from (IP and port). if your SER and red5 on the same lan and you send call via 3rd party service provider like voipstunts it might be that media is going directlly from red5 to the service provider, unless your proxy configured to act as media relay.

  3. if you use red5 on linux read in this forum how to compile it on your Linux server - some users compalined about using the red5 release on Linux cause problems until locally compile the source code. (we added the make.sh to the latest release, but might be you will need edit the file to your enviroment)

  4. I suggest you to start with openfile with red5 plugin on windows as its more easy to install and also tested by more users, if things work for you on the windows ver go and try on Linux.

I am myself using the openfire version and not stand alone red5 even so sip stack is same and should not be any big diffrence.

hope its help

Lior

one more thing

i think you mix keep alive with sip signaling. “destination port unreachable” is part of the keep alive and not a sip message (more like ping).

it can be that your firewall or proxy allow sip , but not icmp.

i noticed your session expire header in 200OK come from your proxy is 3595 sec and might be that your proxy do not answer to the keep alive ping and you get destination port unreachable. (i think its not part of the sip session, check in wireshark what type of message is it, i bet its icmp keep alive)

if your proxy and red5 on same lan the keep alive have no use and can be shut off in sip.cfg

Lior

Lior,

Your absolutly correct about the ICMP.

I hope to setup openfire on a server that belongs to the same lan as my sip setup. I will post the outcome shortly.

If you get a chance to see this, do you think there is could be a codec mismatch between Red5 and my sip?

Luke

hi

In voip like in Voip its can be anything

I don’t think its codec mismatch because red5 use only one codec which is supported on 99% of voip equipmnet (G711).

if we where talking about voice quality (meaning you have some sort of voice) than you could play with the media packet size …

in your case no voice at all on both sides. my guess will be that you did not setup your ser correctlly to act as Media relay.

or maybe i will ask you first that:

is the account details you provided is register on your proxy or is it directlly to voipstunts?

the reason I ask you is because in the sdp of the 183 message your side ask media on the same ip as the proxy = the proxy is used as media relay.

check your firewall if the ports used to media are opened and check your media relay configuration on your proxy.

Lior

Hi Lior,

I managed to setup openfire on one of servers within the same network as the sip server. Still no audio.

Wiresharek:

552 25.554896 source ip(Public IP) openfire ip(Destination) RTMP Audio Data[Unreassembled Packet [incorrect TCP checksum]]

Within this branch:

Transmission Control Protocol, Src Port: sasp (3860), Dst Port: macromedia-fcs (1935), Seq: 3812, Ack: 3633, Len: 29

Flags: 0x18 (PSH, ACK)

Checksum: 0xc110 [incorrect, should be 0x3a88 (maybe caused by “TCP checksum offload”?)]

Real Time Messaging Protocol (Audio Data)

[Unreassembled Packet [incorrect TCP checksum]: RTMPT]

Luke

i don’t have problem with tcp checksum on wireshark and also would not count on wireshark checksum messages.

i had in the past older version of wireshark that did not have checksu,m error and newer version that indicate checksum error.

can you see any rtp stream in g711 between red5 to your proxy?

if any you can analyze them in wireshark and make it as .au file and listen to it.

try first use pc with red5phone open in browser on the same lan as your red5 server and your proxy - check if you get wireshark checksum error.

make same test when you come from diffrent subnet and see if you get checksum error. might be that you have some devices in the middle that change TCP packets like adding QoS,taging…

Lior

by the way I tried put your account in X-lite and make a call and I had no voice so I think your problem is not red5.

it is the way you process the media.

on my second call I got IVR saying “your account balance is insufficiant …”. the problem is we can not get this messgae to red5phone because its early media in 183 progress meassge with SDP. red5phone open voice just after 200OK (it is not supporting early media).

so to make test you need to have balance to make call that can be answered.

Lior

Sent you an email Lior.

Luke

Lior,

I have attached 2 file logs (Wireshark), one with a softphone and one with red5phone(Standalone).

The softphone works flawlessly (2way audio) but the red5 (No audio both ways) does not.

I hope you find the clue here, both calls being made to remote server which is not in our LAN. Remote server is actual server being used for sip services with PSTN out as well.

Thanx

Luke
sip.log6_red.txt (3812 Bytes)
sip.log6_softphone.txt (2569 Bytes)

hi, can you tell me how to setup openfire & spark with SIP phone? thanks!

It seems like SIP threads are all dead.