Openfire 3.10.0 + OFmeet 0.1.4

Basic video seems to work, but the screen sharing with Chrome plugin .5 gives error: “Unable to switch video stream.”

Base installation is running on Ubuntu 14.04.02 with OpenJDK 7 (installed with the .deb file)

Is anyone else experiencing this?

Yes, there seems to be an issue with screen sharing. I think latest chrome browser updates may have broken it. I will take a look as soon as I have a free moment.

Hi Dele,

Thanks for the reply. It looks like you’ve done a couple updates on the plugin. Any idea about what’s causing the screen share issue?

Screen share works fine for me in latest code

Hi Dele,

I got the same error massage, when i use screen sharing, and then sometime others can see the shared screen sometimes not, i tried and didn’t find when it would work fine.

And there was one more thing happened: the “share screen” button cannot click again when i stoped the screen sharing, the “share screen” icon is still on after i stoped screen sharing.

Would you please tell us what’s the recommended environment for openfire 3.10.0 and meetings 0.5, os version, java version, chrome version …

My chrome is the latest 42.0.2311.135 m, openfire is 3.10.0, meetings plugin is 0.5,openfire installed on rhel 6.6 x64, java is ojre-1.7.0-openjdk.x86_64 (i tried to change to Oracal JDK jdk1.8.0_45 x64 and restart openfire service, but didn’t changed anything)

BTW, We just updated(should be “replaced”, we just installed new openfire on a new server, and configed ldap for user auth.) openfire from 3.6.4 to 3.10.0, all the users updated spark from 2.5.8/2.6.3 to 2.7.0, it works fine now. Thanks a lot to all of you for your great works.

We look forward to your updates. Thanks again.

use ofmeet latest 0.1.7 and latest ofmeet chrome extension from app store with https://

1 Like

I updated the latest ofmeet (0.1.7 ), it works fine now… Thanks a lot!

This is rather disappointing…this whole time I thought we’d be able to use ofmeet via chrome browser directly. That was the whole reason I decided to try using it. I guess there’s still a need for Spark…

Is there a way ofmeet can work without Spark? That’d actually be pretty awesome.

Looks like ofmeet actually just opens up the browser. My bad.

I’m using the default installation of OpenFire 3.10.0 with ofmeet 1.7, screen sharing still does not work…

Served by Ubuntu 14.04.2 x64 and java-7-openjdk-amd64

Is there anything I might be missing?

Chrome Version 42.0.2311.152 m (64-bit) with OpenFire Meetings Extension 0.0.5.

Anyway, thanks for responding to this thread and working on this project, Dele.

You are welcome

Does each chrome user have the openfire meetings chrome extension (Openfire Meetings Chrome Extension - Chrome Web Store ) installed?

Not needed for videoconferencing, but required for screen and application sharing

And don’t forget to open the conference URL with https://

Hi Dele, What’s the suggested firewall ports to open for ofmeet?

If i open udp ports 50000-60000 on firewall, it looks like there’sa high chance of connection successfull.

But if i close udp ports 50000-60000 on firewall, there would have 50% chance to connect success, if tried to join meet several times by click "Hang Up "and “Join again” .

Did you use the http binding or some other high-tech solution to collect all the video and screen share streaming into just on port “7443”?

If so, that’s very cool, I can just open 7443 for ofmeet on my ext-firewall.

Here are the ports opened on my firewall:

TCP 5222-5223

TCP 5229

TCP 5269

TCP 7070

TCP 7443

TCP 9090-9091

I think openfire with ofmeet is the best choice for My VC and Screen sharing Project now, I’d like to express our highest respect for your great work and kind help!

You determine the TCP websockets port for XMPP and audio/video UDP ports in the admin web page. The default is 5000-6000 for UDP media and 7070/7443 for XMPP websockets

Sorry to trouble you again. Pls help:

I found openfire responsing slowly this morning, memery is up to 90%(OPENFIRE_OPTS="-Xmx3072m"), so i tried to change java to oracle jdk1.8.0_45 64bit version, and set OPENFIRE_OPTS="-Xmx8192m", maybe openfire can use more mem, then I restart openfire.

Openfire and Spark clients just fine, but ofmeet didn’t work.

I tried to change back JAVA_HOME to /opt/openfire/jre, and restart openfire. didn’t fixed.

JAVA_HOME=/usr/java/default (Openfire 1.7.0_79 x86_64) doesn’t work too.

The config file is:

[root@eim ~]# cat /etc/sysconfig/openfire


If you wish to override the auto-detected JAVA_HOME variable, uncomment

and change the following line.




And the error log shows:

2015.05.19 19:06:40 org.jivesoftware.openfire.session.LocalOutgoingServerSession - Error trying to connect to remote server: lookup:

2015.05.19 19:06:40 org.jivesoftware.openfire.session.LocalOutgoingServerSession - Fail to connect to for

2015.05.19 19:06:41 org.jivesoftware.openfire.session.LocalOutgoingServerSession - Error trying to connect to remote server: lookup:

2015.05.19 19:06:41 org.jivesoftware.openfire.session.LocalOutgoingServerSession - Fail to connect to for

2015.05.19 19:06:44 org.jivesoftware.openfire.session.LocalOutgoingServerSession - Error trying to connect to remote server: lookup:

2015.05.19 19:06:44 org.jivesoftware.openfire.session.LocalOutgoingServerSession - Fail to connect to for

Use ofmeet 0.1.7. Look at admin web page and confirm your focus jid is something like

Thank you, I changed focus to on the admin web page, and reload meetings plugin. Fixed!

Thanks a lot!