powered by Jive Software

Openfire 3.3.0 problem with previous group chats

I did a test upgrade to Openfire 3.3.0 from a previous wildfire 3.2.2 on my devel machine…

I have 150 some muc rooms defined in the postgres database (nothing custom here). On the 3.3.0 admin console, none of those rooms are listed.

Then I try to create a room via the admin console by the same name and get a ‘‘room already exists’’ message. Strangely, the room then finally appears on the Room listing. Then I attempt to configure that room and get an error:

org.jivesoftware.openfire.muc.ConflictException

at org.jivesoftware.openfire.muc.spi.IQOwnerHandler.processConfigurationForm(IQOwn erHandler.java:359)

at org.jivesoftware.openfire.muc.spi.IQOwnerHandler.handleDataFormElement(IQOwnerH andler.java:309)

at org.jivesoftware.openfire.muc.spi.IQOwnerHandler.handleIQ(IQOwnerHandler.java:8 7)

(snip)

Any thoughts on this? No errors in server logs… I’'ve got the orginal setup backup, so can try whatever to see what the trouble is…

thanks!

daryl

I tried this again tonight and things worked?! I must have done something wrong before. My appologies.