powered by Jive Software

Openfire 3.4.0 Alpha 2 exception in CommonsLogFactory

2007.09.07 11:51:22 [org.jivesoftware.util.log.util.CommonsLogFactory$1.error(CommonsLogFactory.java:87)
] Line=19 The content of element type "dwr" must match "(init?,allow?,signatures?)".

This appeared just now, with basically no activity (2 users logged in, idling).

I did modify some source files to change names in database table fields, compiled and run using Java 1.6.0_02.

Any need to worry about this? How to fix?

Allright, forgot to search before posting. Found this thread: http://www.igniterealtime.org/community/message/139863#139863

It might be my own registation plugin then, which I had developed for 3.1.1. I will investigate.

Edit: I use org.jivesoftware.util.Log and only for

Log.warn(string);
Log.error(throwable);
Log.error(string);

I don’t know what else can cause this. Please help!

I just upgraded to Openfire 3.3.3 and I get the same error. I have all the free supported plugins installed and no custom plugins. It looks like the error shows up the first time you visit the “Plugins” tab in the Admin console. The error did not appear on Openfire 3.3.2. I also tried removing all the plugins and it still gets the error.

Chris