powered by Jive Software

Openfire 3.4.5 + MySQL + Ast-IM 1.40 = No CallerID

The presence works just fine… updates status to say ‘On the Phone’ and back to ‘Available’ when hung up. BUT, the popup notification keeps saying ‘Incoming Call, No CallerID Available’. I’ve tried this over both analog and sip trunks, does anyone have any ideas???

Openfire 3.4.5 + MySQL + Ast-IM 1.40, Help!?!?!?

  • J

Openfire

Server Name: my-system.intranet.local (also tried my-system and 192.168.x.x)

Asterisk-IM

Server Name: My-System

Server Address: localhost (also tried 127.0.0.1)

Port: 5038

Username: openfire

Password: *******

Asterisk Queue Presence: Yes

Drop-down device selection: Yes

Default Caller ID: My-System

Dial Command Variables:

Firstleg Timeout:

Username: jason

Device: SIP/123

Extension: 123

Caller ID:

Primary: checked

Spark

Username: jason

Password: *****

Server: my-system.intranet.local (also tried my-system and 192.168.x.x)

Which version of Asterisk do you use?

Do you see the caller id on your phone on incoming calls?

Asterisk 1.4, and yes… CallerID is displaying correctly on the phone (and vTiger, which uses AGI).

  • J

I am having the same problem

I get this in my logs:

SEVERE: Unable to set property ‘name’ to ‘Local/1101@from-internal/n’ on org.asteriskjava.manager.event.QueueMemberEvent: no setter

Someone has got to figure this one out. Spark is PERFECT for me, but the darn no caller ID is available is driving me nuts!

Ok, I finally figured this one out.

After spending months trying to figure this out on my own, I started the Spark Debugger, and found that the Elastix/Asterisk server was not sending the caller ID info to spark. So obviously this is not sparks fault.

I ended up temporarily wiping my PBX and starting from scratch to see if it made a difference, and it did! But after reconfiguring everything the problem came back. After some trail and error, I found that if you configure a follow me using any of the ringallv2 ring strategies and have more than 1 extention configured in the follow me list, or use a ring group, it messes up the caller ID info sent to Spark. I opened up a ticket with FreePBX.

Sorry for pointing the finger at you Spark!