Openfire 3.6.2 has been released

We are happy to announce a new release of Openfire. The new release includes important bug fixes and a few small improvements. The complete set of changes can be found here. Remember to update the connection manager module too since some of the fixes apply to this module.

Download Openfire from:

Download Connection Manager from:


Openfire Team

Working fine on my test server. Will upgrade my main server on Friday. Waiting for the Flash clients users reply.

Hi Gato,

“here” should link to


Updated my test machine, no problems so far. Primary server update scheduled for tomorrow.

Excellent. Has been up now since 22nd and no problems so far.

Thanks for anyone using their time to make the new release possible


Plugins still don’t update correctly. Both the monitoring and sip plugins failed to upgrade with as usual under 3.6.2.

Yeah, Todd. I have commented on that ticket after trying out the nightly build. Maybe it improves some other issue with the plugins. But i’m having the problems only with my Windows box. On Linux plugins are installing and updating fine.

That has been the case for many build versions. Linux seems to release the plugins for upgrading windows does not. On window you need to stop the server delete the old plugin and instll the latest either manually or via the admin site.


I upgraded from 3.5.2 yesterday and I cant access the second level of Tabs (e.g. the Gateways Tab under Server). Tried with Firefox, IE and Opera none of the Browsers worked…

Any suggestion?

Thank you,


I am upgrading from 3.5.2 on Ubutu 32-bit OS.

This is what I did.

  1. I stopped openfire and backed up the entire /usr/share/openfire folder.

  2. I did dpkg -i openfire_3.6.2-all.deb and the install went fine.

  3. I opened the admin console to setup initially and during the database config part, I am getting this error

The Openfire database schema does not appear to be installed. Follow the installation guide to fix this error”

Googling this brought me to - but that is a Postgres install. I am using the embedded-db. No funny business of connecting external db. Bypassing the database config part and proceeding to console doesn’t help because once i login, a brief java exception is thrown.

Can anyone tell me how to get around or actually sort it out?

You need to upgrade all the plugins too.


Fixed and Openfire is on version 3.6.2

See the 1st post here:

Thanks to @Daniel Henninger.

The failure is a due to corrupt database.

Steps to fix:

  1. Stop and Backup the entire Openfire folder.
  2. Install the latest version deb package.
  3. edit resources/database/upgrade/17/openfire_hsqldb.sql file in openfire folder.
  4. remove every line above the following text:

// add new indexed column to mucRoom
CREATE INDEX mucRoom_serviceid_idx ON mucRoom(serviceID);

There would be some 10 lines to remove.

  1. Login to the admin console using http port 9090.

  2. Follow on screen instructions and this the Database configuration part should go smoothly.

Gato , 3.6.2 version is still not closed in JIRA.