powered by Jive Software

Openfire 3.6.3 enabled 9091 port?

Hi all,

Today, I installed new Openfire 3.6.3 version but new version is not enabled 9091 port for web console.

How can I enabled web console security?

Best regards,

Are you able to login with 9090 port? What do you see on the start page then? Is 9091 listed in the list of ports? Maybe there is an exclamation icon saying about something is wrong. Maybe you have deleted your certificates while updating Openfire. Then you can try to generate or add them again.

Hi wroot,

Thank you for quick response. I installed new one via tar extract command. Because I would like to run openfire with non root privilege.

The 9091 port is not listening in system now. I can access console with 9090 port, connect to server from spark and other ports(7777, 5222) are listening in normally.

Best regards,

If you see such picture when you login to 9090 port:

op_cert_error.jpg

Then you have probably overwritten your certificate keystore when you were extracting the new version (/openfire/resources/security/ dir). You should make a backup of that dir before upgrading and then copy your backup on top of the newly written files. Now you have to go to Server Settings > Server Certificate and import your existing certificate or generate a self-signed one (less secure). Then you shall see 9091 port listed and you’ll be able to login to port 9091.

op_9091_port.jpg

In your case the icon will rather be like this:

op_cert_error2.jpg

Such icon will be shown with the default certificates keystore after the upgrade. In my first example the icon was about the corrupted keystore.

Thank you for your visual snapshots.

In Server Certificates tab I can see this message: *Certificates were modified so HTTP server needs to be restarted. Click here to restart HTTP server. *

And here is my snapshots but it has no icon around here like your snapshots. I can not insert image from WYSIWUG of this forum so I attached some files.

Thank for your help.

Best regards,


Have you tried to click on that link to restart http server? The same result should be after restarting the Openfire. In you screenshots i see that certificates are in place and clients can already use them (icons with a lock), but 9091 is not showing up. 9091 is related to Openfire’s internal http server, so http server should be restarted.

Also, can you tell what files do you see in /openfire/resources/security ?

1 Like

Great!!! It works when I click on restart-link. I did not get this action with previous version, it is default. Is this necessary for 3.6.3?

Here is list files in security folder: client.truststore, keystore, truststore.

The conclusion that, when I upgrade a new version, I have to backup openfire.xml, sql dump data and extra security folder.

Thank you very much.

This was the same with the older versions. You have to copy back backup security folder after the manual upgrade (extracting). Tar version has default keystore, truststore and clienttruststore files in security dir.

Glad to hear everything is working now

Hi wroot,

I look again server properties that I uploaded previous post. (http://www.igniterealtime.org/community/servlet/JiveServlet/download/187084-3830 /Properties.PNG).

Under Server Information tab, Server Properties has Server Name value. But Environment has not value for Host Name.

I have another installed server then Server Name is domain name and Host Name is OS host name.

What is it wrong?

Best,

Can’t say why and what is wrong. Maybe this machine doesnt have a hostname. Two of my servers has hostnames in this place (Windows and linux). I think you better create a new thread for this problem, because this thread is already marked as answered and less people will take a look here.