powered by Jive Software

Openfire 3.7 & FastPath

Before I upgrade or do any kind of work with 3.7…does FastPath actually work? I tried the beta not to long ago and noticed/read that FastPath and the WebChat was not working correctly. Can someone confirm or deny whether this is working or not? I would greatly appreciate it everyone.

Regards,

Eric @ 500M

Fastpath DOES Work. However webchat does not install into openfire itself properly. But if you deploy it to a jsp server, at least Tomcat in my case worked, and connect it up to the server it works fine. It still has the same bug that the xmpp domain in openfires system properties have to match the URL you give to web chat, but I demo’d it on my staging server and it worked. Going to go live with it either tonight or tomorrow.

I had the same results as NinjaTek last night…you can’t deploy webchat into OpenFire, but deployed independently seems to work fine.

I know this may sound bad…but I am a windows guy…I am running this on a CentOS 5.5 VPS and I know some linux…however how would I go about having webchat be loaded and working within Openfire through a JSP server? Is there any kind of documentation on how to get something like this setup? I would be forever greatful.

Respectfully,

Eric @ 500M

Does anyone know if there is going to be work on the Web Chat to make it work again with Openfire? Currently I run 3.6.4 and a lot of the fixes, etc. would fix a LOT of my headaches…but unfortunately my organization relies a LOT on fastpath/webchat working…I just need to know if I need to start requisitioning a Tomcat/JSP server so I can get this to work, or if it’s in the works I can wait to update…

I would gladly see it back the way it was prior to 3.7.0, there is no need to make everyone installing additional webserver to serve Webchat, unless anyone can tell me how to make it work without installing additional server.

Does anyone know how to install webchat in tomcat 6?

Have a look at App Manager How-To, especially “Deploy A New Application Remotely” section.

1 Like

thanks, it was pretty easy

Wasn’t it

Anyway I had to install Tomcat since I did not have it and it was not complicated as well so I’m set now too.

I had Tomcat but no Fastpath tab in OpenFire admin so I had to uninstall the plugin and re-install.

After restarting the server was able to connect to my workgroups again.

Requesting NinjaTek,

Could you put some light on how to do this?

I will be really very greatful. I have been trying this for weeks and nothing is working out.

Please help.

Regards,

Mac.

  1. Install Tomcat on a box.

  2. Deploy webchat.war to it

  3. Point it to your openfire server

That’s it.

First of thanks for your prompt response.

I have installed the tomcat on the same desktop on which the openfire server is installed.

I deployed the webchat.war in to tomcat6/webapp directoy as instructed. When I point to http://my-server-ip:8080/webchat I am able to see only 2 lines on this page as you might be aware :

"

List of available workgroups within Fastpath

Click on one of the following workgroups to join. "

But no groups are shown here. I am using Spark IM client with fastpath plugin to connect to groups created on my Fastpath server.

I am able to connect to groups that means that Fastpath is working fine.

But how do I get the list of available groups on webchat page?

Am I missing something here?

Many thanks in advance.

Regards,

Mac.

I’ve had that happen before, however if you use the URL under text settings for the fastpath workgroup you are trying to reach and put it on an html page that can communicate with the tomcat instance, it should display the workgroup button.

I belive that issue happens when the url you set when setting up the webchat portion doesn’t completely match the xmpp.domain set in the openfire server, for which i do not know how to resolve that other than making sure that they match. There are instructions on here somewhere for deleting the webchat config file and/or editing it. Just remember to reload the application in tomcat manager after any changes.