powered by Jive Software

Openfire 3.8.2 & Monitoring Plucin 1.3.2 beta1

Hi,

after trying to install on 3.8.1 the plugin in versione 1.3.1 rc1 I decided to retest the deploy the new version on an upgraded 3.8.2 openfire server.

Before doing anything i stopped the server, cleaned & recreated the ofrrds table, restarted the server and deployed the plugin in the new release.

The result unfortunately did not change at all.

Once the server load the plugin it start to eat lot of ram and dumps in the of’s error log this message:

rg.jivesoftware.openfire.reporting.stats.StatsEngine - Error initializing Rrdb

java.io.IOException: The underlying backend has no canonical path

Does anyone know what could be the problem? I do have a standard openfire installation simply attached to ad ldap with standard plugin deployed (such as fastpath, jappix, jingle nodes.

Regards

Giorgio

Just an update i attach the full log of the error:

2013.07.24 10:25:39 org.jivesoftware.openfire.reporting.stats.StatsEngine - Error sampling for statistic muc_outgoing

java.io.IOException: The underlying backend has no canonical path

at org.jrobin.core.RrdDb.getCanonicalPath(Unknown Source)

at org.jrobin.core.Header.validateHeader(Unknown Source)

at org.jrobin.core.RrdDb.(Unknown Source)

at org.jrobin.core.RrdDb.(Unknown Source)

at org.jivesoftware.openfire.reporting.stats.StatsEngine$SampleTask.run(StatsEngin e.java:362)

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)

at java.util.concurrent.FutureTask.run(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

The db used is Postgresql 9.2 maybe someone could help ?!

Hi some other infos.

I trid to perform a new fresh install with the same db engine and once i try to upload the plugin I obtain exactly the same error.

At this point i tried to install a new instance on mysql 5.6 (with the modification on the scrpts suggested by dele) and i reloaded the plugin successfully.

Could it be a problem on the data structure?

Regards

Resolved at the end…Crossing postgres 9.2 and bytea datatype I found an old arguments that explained how the bytea default changed since 9.x release: http://community.igniterealtime.org/thread/43807

I removed the plugin, deleted the table,forced on postgresql.conf the escape (bytea_output=‘escape’), stopped openfire and postgres…restarted both and recreated the table.

After doing this i tried to reinstall the plugin and now statistics works like a charm!!