powered by Jive Software

Openfire 3.9.0 has been released

The Ignite Realtime community is happy to announce the release of version 3.9.0 of Openfire! Downloads for various platforms are available here.

Openfire is a real time collaboration (RTC) server licensed under the Open Source Apache license. It uses the only widely adopted open protocol for instant messaging, XMPP (also called Jabber). Openfire is incredibly easy to setup and administer, but offers rock-solid security and performance.

There are a few important fixes with this release, be sure to checkout the changelog for more details.

As always, we welcome your feedback, suggestions, tips, hints, questions and other contributions in the Ignite Realtime Community pages.

We are also looking for people interested in helping to develop Openfire! If you enjoy hacking at Java code and would like to pitch in, please let us know on the forums.

Update 6 Feb 2014 20 UTC: There was a problem with the initial build of 3.9.0 and the packaging of the bouncycastle libraries. This has been fixed. The following MD5 checksums should be used to check the files you download.

md5sum
filename
e68c95feba256d8f010682b845a901e2

openfire_3_9_0.dmg
a5cf6e3121aaf8b8367381db0eddb7e5
openfire_3_9_0.exe
a0b4e5d15e4e9c0ac9f5fb8645a32faf
openfire_3_9_0.tar.gz
a3088db15e73c884f22ff14842d80642
openfire_3_9_0.zip
d09cb027cf537c866c2e8896b1f3125d
openfire_src_3_9_0.tar.gz
8fffc005508684e2fb23314df8d4f502
openfire_src_3_9_0.zip
674b86bc209ca51e71fe8fe9f05883f4
JSopenfire-3.9.0-ALL.pkg.gz
3e883a6c8a8504f6a0934b7054efce66
openfire-3.9.0-1.i386.rpm
8d661624495d232323ae061246b47ecd
openfire-3.9.0-1.src.rpm
48167fb89ba804e297faa70b37da1b95
openfire_3.9.0_all.deb

1 Like

Great news!! Thanks! Will try it soon!

One thing I noticed in the changelog though: Some issues are targeted for 3.9.1 release in Jira. Are they included in 3.9.0 nonetheless, (e.g. OF-720, OF-722, …)?

My bad, I have corrected it, I hope.

Good to see some new improvements to this remarkable xmpp server.

You may want to check the links to the documentations on here: http://www.igniterealtime.org/projects/openfire/documentation.jsp

Install Guide, Upgrade Guide etc. throw a 404 file not found for me :wink:

That caught me by surprise

Excellent news. Now I have to write a blog or document on how to use the Jitsi Videobridge plugin with Fastpath using candy and ofmeet

1 Like

Sorry about that, I fouled that up too. Should be fixed now.

1 Like

Daryl,

I can’t get 3.9.0 windows version working. It is behaving like the nighlty build showing wrong version of files in the lib folder. I had to replace them with my local SVN copy before OF started working

Dele,

Please provide specific examples of what you are seeing.

2014.02.06 15:04:24 org.jivesoftware.openfire.container.PluginManager - Error loading plugin: C:\Openfire\plugins\admin

java.lang.ExceptionInInitializerError

at org.jivesoftware.openfire.container.AdminConsolePlugin.startup(AdminConsolePlug in.java:107)

at org.jivesoftware.openfire.container.AdminConsolePlugin.initializePlugin(AdminCo nsolePlugin.java:216)

at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java :483)

at org.jivesoftware.openfire.container.PluginManager.access$300(PluginManager.java :80)

at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:1073)

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)

at java.util.concurrent.FutureTask.runAndReset(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Caused by: java.lang.SecurityException: SHA1 digest error for org/bouncycastle/jcajce/provider/asymmetric/DSA$Mappings.class

I think it is the same error we had with the nighlty build. I have checked the jar files in the lib folder and some have different sizes from the latest ones in the SVN.

I wonder if the updated bamboo is not doing what it is supposed to be doing. Uggg

Dele,

Please try these files: http://bamboo.igniterealtime.org/browse/OPENFIRE-NIGHTLYWINDOWS-1212/artifact/sh ared/Project-Windows-distribution-files/

It gave the same error

24/09/2013 16:35 54,829 activation.jar

28/11/2013 19:06 248,366 bcpg-jdk15on.jar

28/11/2013 19:06 629,662 bcpkix-jdk15on.jar

28/11/2013 19:06 2,476,362 bcprov-jdk15on.jar

24/09/2013 16:35 112,341 commons-el.jar

24/09/2013 16:35 641,570 hsqldb.jar

24/09/2013 16:35 407,502 jasper-compiler.jar

24/09/2013 16:35 77,056 jasper-runtime.jar

24/09/2013 16:35 74,639 jdic.jar

24/09/2013 16:35 294,726 jtds.jar

24/09/2013 16:35 2,848 log4j.xml

24/09/2013 16:35 362,975 mail.jar

24/09/2013 16:35 855,948 mysql.jar

21/01/2014 14:29 7,601,207 openfire.jar

24/09/2013 16:35 448,014 postgres.jar

24/09/2013 16:35 132,425 servlet.jar

24/09/2013 16:35 9,750 slf4j-log4j12.jar

24/09/2013 16:35 71,936 startup.jar

24/09/2013 16:35 57,344 tray.dll

These are the files from the SVN in my 3.9.0 alpha. The bouncy castle files bcpg-jdk15on.jar, bcpkix-jdk15on.jar and bcprov-jdk15on.jar are all different sizes from those in the build and could be the reason for the exception message I am getting when Openfire starts and tries to load the admin console. Most likely a different version.

Hmmm, when I extract the zip file, I end up with .pack files , boggling.

I experienced the same exact problem as @Dele Olajide.

Tried an in place upgrade.

First I received a permissions error for the log files… So I reran Openfire “As Administrator” (this cleared that up).

But from then on I received the same error as Dele.

I even completely uninstalled my previous insallation (except the database [Microsoft SQL Server]), and reinstalled still to no avail.

So, for now I wiped the newest installation and then dug up the link to the build right before this, and had to reinstall the previous release.

I’m running Windows Server 2012 with all the latest updates, and Microsoft SQL Server 2012 with all of the latest updates.

The Run As administrator requirement rised after the install4j update and changes to min/max Java requirement (was 1.5/1.6, now it’s 1.7/1.8). This was done to Spark, but probably Daryl also did this to Openfire build plan (hence the same symptom, installer has no UAC shield icon attached, so Windows doesn’t recognize it as an installer). Probably newer update4j does something differently and currently builds installers that are not recognized by Windows as program installer. We haven’t been able to find out what exactly does this in the config. So, from now on we have to remember to install Openfire/Spark on Windows (Vista/7/8/2008/2012+) via Run As administrator. Though, if you have elevated rights, you probably don’t need to do this.

So, what’s the plan? I see Daryl is doing lots of updates on tickets in Jira. Wait till 3.9.1 soon?

Daryl released Openfire 3.9.1 moments ago. That version addresses the problem with starting Openfire that got introduced in 3.9.0.

Wow, that was fast! Good job on the speedy work/release!

Does anyone know if openfire saves the active sessions xmpp client in a database table?
I have searched and not found here.

If it saves someone know where and I thank you. I need to create a script that make an interaction with these data.