powered by Jive Software

Openfire 4.0.0 Beta


#1

Wouldn’t it be great if your favourite XMPP Server was almost about to make a major release? Well, stop imagining, and start downloading, because Openfire 4.0.0 has reached Beta status!

This means that while we’re quite sure there’s bugs to be found, we believe the server is stable enough to use for formal testing and careful use in non-critical production environments (which means, basically, we’re using it on igniterealtime.org itself and our own servers).

So if you’re keen to help make this the best Openfire release we’ve ever made, then download, install, and keep us posted in the chatroom at open_chat@conference.igniterealtime.org

Download from here: Ignite Realtime: Beta Downloads

A Change Log is here: Openfire Changelog

And SHA1 checksums are below:

**Format
**
**Checksum
**
**Filename
**
Mac OS X
6b498b67a47f81969352ad8c6a94a12cf50aa946
openfire_4_0_0_beta.dmg
Source (UNIX)
af846e168fb446c3001711c5a8337f5e7494cc47
openfire_src_4_0_0_beta.tar.gz
ZIP
d302d9c98c838edec26a60de6ed35e09f11f03a6
openfire_4_0_0_beta.zip
Tarball
4957d88b5cbaf087207bd8b459690f7f23021a45
openfire_4_0_0_beta.tar.gz
Windows
5940fb8f1ea0c75512e592dbecb058896c84c30d
openfire_4_0_0_beta.exe
Source (ZIP)
8d5c3553534762792d5413e23f9913c9dac98b0d
openfire_src_4_0_0_beta.zip
Debian / Ubuntu
3f37ec574c3fdca231b94b0c67f7d5c3d37fe2ea
openfire_4.0.0.beta_all.deb
Source (Redhat / CentOS)
e73d303bc58e19a2d714c5bd8b3f7d2952305cbe
openfire-4.0.0.beta-1.src.rpm
Redhat / CentOS
16f76f7eb2eea1b49d85d0f50a673a3c418cc42d
openfire-4.0.0.beta-1.i386.rpm

Enjoy!


#2

WTH ?!? No x64 version?!? What are u waiting for?!? This is 2015 !!! Not 2005 !!! Server is always maxing out!!! We need the x64 for more reserved memory!!!


#3

umm cant you simply build x64 version yourself ?


#4

Sorry, but I don’t have any skills whatsoever in building any type of builds, x64 or x86

That’s why I’m posting this, to see if the devs make one… there’s a lot of people in the forums needing for a x64 build…


#5

use the files from here


#6

Watch out for some plugins that have embedded web services or use virtual connections like Openfire Meetings (ofmeet.jar). The current versions will fail. You need to build compatible OF 4.0.0 beta versions from source or download from here.


#7

Here Openfire on Windows x64 with Java x64 ??

Does it really work with 4 beta ?!

I tried with 3.10 RC and it didn’t worked but maybe it was me doing something wrong…


#8

I have to agree with Nuno, in nearly the year 2016, the idea of not having an 64 bit installer makes no sense. I have used the patched files for previous Openfire 3.10 installs and have been running OpenFire in 64 bit on Windows without any issues at all, but it still makes no sense to me why there is no native 64 bit installer available.


#9

damn dude, there’s a nicer way to ask about x64. you admit you don’t have the skills to do it yourself. presuming you’re using a free version like everyone else. the entitled tone is a little tiring. find a way to contribute, and/or maybe consider being a little less demanding.


#10

It maybe 2020 whatever year, but as all projects here are free and moved forward by a small number of volunteers, you can’t expect anything. If you think this is easy, then provide patches and help to reconfigure bamboo to produce x64 installers.


#11

wroot wrote:

It maybe 2020 whatever year, but as all projects here are free and moved forward by a small number of volunteers, you can’t expect anything. If you think this is easy, then provide patches and help to reconfigure bamboo to produce x64 installers.

I’m not sure if this was directed to me, but, two points

  1. The patches have already been out there for 3 years. Openfire on Windows x64 with Java x64
  2. Replace the 32 bit JRE with the 64 bit JRE.

Considering Windows Server has been 64 bit only for the last 5.5 years, and will never release a 32 bit version ever again, I don’t think its an unreasonable request to have of a “major” release. Clearly the entire product doesn’t have to be re-written here, we’re just talking about including some different files in the installer.

I’m making a reasonable request and justifying the request. Please leave the ad hominem attacks of having “expectations” and “thinking this is easy” at the door. I never said I had any expectations and I never said I thought it was easy. Just because I don’t know how to “reconfigure bamboo to produce x64 installers” doesn’t mean its any less of a good idea.

Merry Christmas.


#12

These are not patches, but precompiled binaries provided by someone and not widely tested (“use at your own risk”). Also it looks like they stop working as Openfire version updates. As i have mentioned there should be a patch for the source code and also a new configuration for Bamboo (system producing installers) so it would produce official working x64 installers (ideally with jre64 bundled). And not just for Windows. As far as i know currently there is only one guy maintaining Bamboo and he doesn’t know it very well (i was asking to change some install4j settings for Spark, but he didn’t know how to do this in Bamboo). So switching to x64 installers seems as not a trivial task. At least in my eyes.

It is a reasonable request for a commercial company or a strong open source project with a big team. I’m participating in this community for 10+ years and i know, this is not the case. There is just no man and brain power to fulfill many requests. My reply wasn’t specifically targeted at you (more at arrogant Nuno demands).

Here, i can file this request in the tracker, but this won’t change much probably [OF-1015] Provide 64-bit installers for 64-bit OS - Jive Software Open Source


#13

Hi there

I want to install openfire 4.0.0 Beta but current password must be ‘admin’ in first installation not work and i can’t complete installation. I’m using Ubuntu 14.04


#14

Thanks for keeping openfire alive and your work happy new year


#15

I love Openfire server! Very simple but robust! I recommend it to follow developers


#16

Hey Saeed, you can skip this step and installation would be completed. I just found that

while as I know, two columns couldn’t be type of LONG in oracle. Might be that is why problem occurring in message archiving with the combination of OF beta 4.0.0 and monitoring service plugin 1.4.7 .

You can see other changes at here : Openfire/src/plugins/monitoring/src/java/com/reucon/openfire at v4.0.0.beta · igniterealtime/Openfire · GitHub

I would suggest we should modify the type of BODY column to CLOB. I think the problem of message archiving would be resolved after making this change.


#17

Hi Aks, i skip that but i can’t login by admin user with password admin


#18

Default current password is : admin

Let’s say you set the password : admin123

so whenever you clicked on continue, it showed you an error. So, just skip the step then login to the admin console with the password ‘admin123’ .


#19

I do what you say but i can’t login with admin123


#20

Try the installation process again, enter the default current password is: ‘admin’, set the your password let’s say ‘admin123’ . Now, click upon Continue button, it will show an error ‘your current password in not correct’. Now again enter the current password and your password then click upon skip the step, it will take few seconds and will show you installation completed. Login to the admin password with username ‘admin’ and password ‘admin123’.

By the way, in current beta version they must forgot to mention default password is ‘admin’ or put incorrect check.