powered by Jive Software

Openfire 4.0.2 Released


#1

The Ignite Realtime Community is pleased to announce the 4.0.2 release of Openfire. This release signifies our ongoing effort to produce a stable 4.0 series release while continuing to work toward a 4.1 release. A changelog of issues fixed indicates 9 issues resolved with hopefully the issue of stale/ghost client sessions being resolved.

As always, please report issues in the Community Forums and you can download this release from our website. Here are the sha1sum’s for the downloads available.

Platform
sha1sum
Filename
Linux RPM
cc675aad91ae28ed8e4dd5f86ff1bd0bed8a6000
openfire-4.0.2-1.i386.rpm
Debian
bcbd2f48f39b59b7d445ee46a42b1a576507af41
openfire_4.0.2_all.deb
Mac
369cbdc069bfabcc9a1fc906026fb21c7ab85905
openfire_4_0_2.dmg
Windows
7c910a8136347f2b35576886dc883b4173ea598c
openfire_4_0_2.exe
Binary (tar.gz)
b21b0087a19c5ae043c66d1b60a6e1070336d15d
openfire_4_0_2.tar.gz
Binary (zip)
1820004f927900ec8a8de4f0ce869a60529aa91d
openfire_4_0_2.zip
Source (tar.gz)
7ce3f9e727582ce6fb05fc82984f87eec160ed6b
openfire_src_4_0_2.tar.gz
Source (zip)
28a9b47186215f7d5056b315a885c19dbbf55f89
openfire_src_4_0_2.zip

As a reminder, Openfire’s source code and development can be found on Github and an active developer discussion occurs within our open_chat@conference.igniterealtime.org groupchat. Please consider helping out with Openfire’s development!


#2

upgrading from 4.0.1 to 4.0.2 - afterwards clients cannot connect to port 5222

if I downgrade back to 4.0.1 clients can connect no problems.

is there an issue with 4.0.2 with clients connecting on port 5222 ?

thank you


#3

Auch - that should not happen. We had someone earlier that had problems while running Java 7. Those problems disappeared when he installed Java 8 instead. At this time I can’t see how this problem would be isolated to 4.0.2 and not 4.0.1, but it is probably an easy enough thing for you to verify.

The Java 7/8 issue is being tracked as [OF-1116] Java 7 incompatibility - Jive Software Open Source


#4

i already had java/8 - 4.0.2 requires 7 to install - it’s a Debian box.

so I reinstalled 8 + 7 and now my whole openfire is screwed up - thanks a million!


#5

recovered from this failure - restored users

still only running ver 4.0.1

tried 4.0.2 and same thing - users cannot connect - i have both 7 and 8 java installed - 4.0.2 won’t install without ver 7


#6

Same here.

Client´s can not connect to the server… i´m using the conversation app on my android phone.

Client´s are online for 2-3 seconds… and then disconnected again.

I have reinstall the 4.0.1 and all client´s can connect to the server again.

I don´t know what happen. I can´t find something wrong.

My Java Setup:

java version “1.7.0_95”

OpenJDK Runtime Environment (IcedTea 2.6.4) (7u95-2.6.4-0ubuntu0.14.04.1)

OpenJDK 64-Bit Server VM (build 24.95-b01, mixed mode)

Greetz

Echse


#7

I can confirm too, is happening to our system too. I can not connect users when i run 4.0.2, I’m downgrading until somebody finds the solution / fix for running 4.0.2.


#8

Is anyone that has this problem not using the Debian package?


#9

Still no Windows x64 version…


#10

Nope, still no Windows x64 version. However, I installed it on Windows 2012R2 and as has become my protocol, replaced the JRE with the latest 64 bit version from Oracle and used the patched files I found in the forum here and 4.0.2 works fine running as a 64 bit process.


#11

Here’s a 4.0.3 alpha release for debian, which hopefully fixes the issues found there

https://bamboo.igniterealtime.org/browse/OPENFIRE-NIGHTLYDEB4-1/artifact/shared/ Project-Debian-distribution-files/nfire…


#12

re. 4.0.3 alpha deb

same issue 4.0.3 alpha does not allow clients to connect

downgraded back to ver 4.0.1


#13

Confirm, same issue with java version “1.7.0_80” on ubuntu.


#14

We think this problem is isolated to running Openfire with OpenJDK 7. OpenJDK 8 and the non-Open, ‘regular’ Oracle JDKs do not appear to cause this problem. A related issue was documented in the OpenJDK issue tracker here: [JDK-8151366] Using JDK8 to compile code for JDK7 (-source 1.7 -target 1.7) does not work if ConcurrentHashMap is used -…

If you experience this problem, please verify what version of Java is used to run Openfire. A good way to do this is to log in to the admin console. On the first page after login, the Java version is listed. If you see a 1.7 version of OpenJDK being used, try running Openfire with a different JVM.


#15

this is on my console …

Environment
Java Version:
1.7.0_95 Oracle Corporation – OpenJDK 64-Bit Server VM
Appserver:
jetty/9.2.z-SNAPSHOT


#16

I might try again doing that


#17

@Anthony R. That shows that you are running Openfire with OpenJDK version 1.7, which is not good. I assume that with that setup, you are experiencing problems. Try running Openfire with another version of Java.


#18

i’m installing JDK-8 at the moment and see if the .deb file will compile to that version … will get back to you after my users are off the system,

thank you for the help


#19

ok had to do major cleaning up of JDK7 - wasn’t that simple but finally got java8 working and installed.

installed ver 4.0.2 of openfire and success clients are now connected to upgrade. Thank you for your help and patience.

Environment
Java Version:
1.8.0_74 Oracle Corporation – Java HotSpot™ 64-Bit Server VM
Appserver:
jetty/9.2.z-SNAPSHOT

Distributor ID: Debian

Description: Debian GNU/Linux 8.3 (jessie)

Release: 8.3

Codename: jessie

NOTE: make sure to install plugin …

Plugin
User Import Export
README changelog

Enables import and export of user data
2.5.0

Ryan Graham
Refresh
Delete


#20

Okay, good to hear that the workaround did the trick. On our end, we’ll continue to work on a solution that will prevent this kind of thing in the future.