Openfire 4.0.2: search fails when * character exists in OpenLDAP uid

Openfire 4.0.2, OpenLDAP:

When searching for a uid with a ‘’ in it, the string that gets sent to the LDAP server has the '’ converted to ‘\5C2a’ instead of the expected ‘\2a’.

OpenLDAP command line tool doesn’t convert - and not converting means that the searches actually work.

Current LDAP settings:

Ldap Base DN: ou=People,dc=domain,dc=com

Ldap Admin DN: cn=Manager,dc=domain,dc=com

We are porting a legacy system to OpenLDAP that previously used MySQL for usernames, where we need to use the * character.

Any advice on how to achieve this?

Thanks in advance.

We resolved this by swapping out LDAP for custom database authentication with SQL.