powered by Jive Software

Openfire 4.2.1 install on windows with java 9 failed

Installing the latest Openfire 4.2.1. on windows 7 failed.

The installation went ok, except for the part when during initial configuration you can enter a password for the admin user. This step fails with a JSP stacktrace: java.lang.ClassNotFoundException: javax.xml.bind.DatatypeConverter.

You can skip this page, but it won’t help. Other failures like : java.lang.IllegalArgumentException happen.

Some digging gives the indication that Java 9 is used without adding the proper modules. This was strange while although a java 9 is installed, The Java_home and the Path is directing to a java 8 version. Apparently the startscripts find still a reference to the java 9 installation.

Tried to force adding the module by adding the line “–add-modules java.xml.bind” to a openfire-service.vmoptions or a openfired.vmoptions but no difference noted.

Also tried re-installation with the -manual option and specifying a java 8, but did not help.

My assumption for now is that my mixup of java version confused the install4j scripts and mixed up things.

The solution for me which worked was using the windows installer with jre included. This worked at once.

FWIW, I don’t think anyone has tested Openfire with Java 9. Java 7 is supported, I know it works well with Java 8, but enough has changed with Java 9 that I’m not surprised it’s causing problems.

Greg

My biggest frustration was that I could not configure/specify which Java version it should use. It just picked one, and this case not the one i expected.

A few of us already tried Openfire with Java 9, unsuccessfully https://issues.igniterealtime.org/browse/OF-1383