powered by Jive Software

Openfire 4.2.1 Security Settings option is missing under Server Settings


#1

I have openfire 4.2.1 setup and running and I am able to send chats from my clients. I want to enable TLS. A quick google search gave results asking me to go to “Server Settings”->“Security Settings”, but I am not able to find “Security Settings” anywhere. It looks like a simple configuration issue or some plugin is missing. Please help me with this.


#2

If your clients are using BOSH or WebSocket, you need to ensure Server Settings -> HTTP Binding has an SSL port defined.

If your clients are using plain-old XMPP, you need Server Settings -> Client Connections -> Advanced config and ensure that STARTTLS is optional or required, and your “Mutual Authenticaion” settings are set correctly.

Greg


#3

gdt is right. Your search results were for some older version of Openfire.


#4

Thank you! I found the settings as suggested above!