powered by Jive Software

Openfire 4.3.0-4.3.2 group creation problem


#1

What is the source of this problem? First, I found that on 4.3.0 I have a constant amount in list of groups. After unsuccessfull upgrade to 4.3.2 version I decided to uninstall Openfire at all. Now I have new 4.3.2 version with 650 acounts. I started creating groups and found that I have only 12 groups and they exist in chaotic order: 1, 2, 3, 4, 7, 10,11,14 etc. Some groups are created and some not. I tried to recreate 5 again and I got “Group already presents”. How is that and what I have to do with it now? numbers here are for example. I can not skip the group in real because those are departments’ names. In accounts list in added to those groups accounts is written “None” in group string. What is it? I didn’t touch Java SDK


#2

What DB do you use? I have noticed problems with sorting https://issues.igniterealtime.org/browse/OF-1685
Although i’m not able to reproduce problems with groups creation, but i saw another report, so i have filed this as https://issues.igniterealtime.org/browse/OF-1686


#3

I use internal DB. I started creating groups only from 4.3.0, might be the problem was even in 4.2.3, I don’t know. I created there five groups and they created fine. After failed update to 4.3.2 i imediately noticed that 6th created group is invisible.

Also, to uninstall OF I used these commands:

sudo rm -rf /usr/local/openfire
sudo rm -rf /Library/PreferencePanes/Openfire.prefPane
sudo rm -rf /Library/LaunchDaemons/org.jivesoftware.openfire.plist
sudo rm -rf /private/var/db/dslocal/nodes/Default/users/openfire.plist
sudo rm -rf /Library/Receipts/Openfire.pkg

Maybe this was not enough?

P.S.: I din’t check if there’s same problem with creating of users, I just used import/export plugin between Openfires

P.P.S.: I analized the group list and I think I got a clue! Invisible groups have long names. What string length is allowed to internal DB?


#4

ofGroup has a max of 50 chars for group name.

Greg


#5

Buena tarde, señores tengo el mismo problema de manera intermitente para crear los grupos actuelmente tengo instalado:

  • Linux centos : centos-release-7-6.1810.2.el7.centos.x86_64
  • Server version: 5.6.43 MySQL Community Server (GPL)
  • Openfire 4.3.2

El error sale cuando cuando se crea el GRUPO y se da clip en guardar configuracion ( pero no siempre sale el error )
El error:
???global.csrf.failed???
Sale cuando da clip en GUARDAR CONFIGURACION DE LISTA DE CONTACTOS
en la opción: Compartir Lista de Contactos (Roster)
NOTA: Envió adjunto el error que queda en el navegador
quedo atento,

HTTP ERROR 500 MENU DE GRUPOS.txt (14,1 KB)