powered by Jive Software

OpenFire 4.3.0 broke this app


#1

I have been running 4.2.3 since it came out. When 4.3.0 came out I thought it would be just as stable. My mistake. After install OpenFire will not start. After trying several things, I removed it and installed 4.2.3 again and now that does not start.

Need help to get one or the other to start.

Before you ask, Yes MySQL is running and I can administrate it with phpMyAdmin. The database from 4.2.3 is there and has the right data and is started with status normal. Also other Java apps do run without error.

Environment
Linux Mint 18.3
Cinnamon 3
Kernel 4.15
Java JRE 8
MySQL 5.7.24-0ubuntu0.16.04.1 (Ubuntu)


#2

What exactly is happening? Clients can’t connect (what client)? Can’t access Admin Console? Any related logs in /openfire/logs/all.log?


#3

Just to comment on stability. Usually major versions (4.x) introduce more changes and can break things. Minor versions (4.2.x, etc.) have less changes and mostly fixes, so updating to minor versions has less chances to have issues. There is a rather small team of volunteer contributors working on projects here, so things can happen. Not many users tested Beta or reported issues (i think maybe 2 in total). Historically bugs are usually caught after the so called stable release here because of luck of interest in testing from the community. I advise to have good backup and not rush with upgrading. When i was running my own Openfire server i usually waited a week or so before updating and looking over forums for issues to pop up.


#4

When attempting to restart OpenFire no message is displayed. It does nothing. When trying to connect to port 9090 it indicates the server is not available.
I can’t get to the Admin Console if it wont connect so I am d-e-a-d.


#5

Any related logs in /openfire/logs/all.log?


#6

When attempting to start Openfire v4.2.3 with /etc/init.d/openfire the message is no such file. And in fact the only thing that does exist is openfire.dpkg-dist.

It looks like the install pkg (.deb) did not even finish the install I would say. After attempting to do this two more times nothing has changed.

No log files created from the install process.


#7

You are trying to install 4.2.3 again? What happens if you try to install 4.3.0? I’m not that familiar with Linux, so not sure how exactly is clean install done. Maybe wiping out install folder and installing again, then go through web setup and connect to the same database.


#8

The Administration Software Manager was used to un-install v4.3.0 and install v4.2.3

The v4.2.3 was installed and working using the same methods. After uninstalling v4.3.0 none of it works.


#9

Confirm the same issue. I installed v4.3.0 on my working 4.2.3 (debian jessie) installation. Openfire 4.3 would not start. I tried to start from a command line “/etc/init.d/openfire start” and nothing happens. Nothing new shows up in the /var/log/openfire/all.log (last entry shows where the server was shutdown for the installation). I removed v4.3.0 and reinstalled 4.2.3, and it would not start. I was using java 7. I added jessie-backports and installed openjdk-8-jdk and ran “update-alternatives --config java” to select java 8. At this point I could get v4.2.3 to run again.


#10

So, 4.3.0 dropped Java 7 support, maybe that’s why it didn’t start for you, s-rod62. But it is strange that you had to install Java 8 to make 4.2.3 work again. I guess something was left behind from 4.3.0 installation after you uninstalled it.


#11

Forgot to mention, that after getting 4.2.3 back working with java 8 - I tried upgrading to v4.3.0 again. Same results, would not start nothing in all.log. So I rolled it back to 4.2.3 again.


#12

The same issue here,
Centos 6


#13

I suggest posting your own topic and provide more information (what you have running, what you try to do, what is happening, logs, error messages, etc.).


#14

I found the solution

I should delete mysql-connector-8.0.12.jar

And download mysql-connector-5.1.42.jar in the lib folder