Openfire 4.3.2 port 9091 not working

I have Windows Server 2019. I try to connect on openfire to web interface to http://localhost:9090 or or is working.

But https://localhost:9091 or or does not working.

I try change to number 9090 to -1 on conf (stop service then change conf then start service) - not working.

Next I try change certificate keystore SSL RSA. After change SSL - port 9091 does not working.

Thank you for your help.

9091 is for encrypted connection. Use https.

I try to https:// - does not working.

Check the logs at /openfire/logs/all.log
Maybe something is using 9091 on your system. Check with netstat -a or Tcpview of 9091 is available and listening.
How do you run Openfire, via service or with a launcher?

I try to change port number:
access to http: 11111 - working
access to https: 11112 - not working

to same as:
access to http: 9090 - working
access to https: 9091 - not working

I runned Openfire over automatic runned service.

I try stopped services and launch openfire server dialog:

Openfire 4.3.2 [16. 2. 2019 0:34:08]
Administrátorská konzole naslouchá na:
Successfully loaded plugin ‘admin’.
Successfully loaded plugin ‘search’.
Finished processing all plugins.
Error starting 5222: null
Error starting 5223: null
Error starting 5275: null
Error starting 5276: null
Error starting 5262: null
Error starting 5263: null

Logs can have some insight.

alllog.txt (255.8 KB)

Do you use Openfire with or without Java bundled? If you are using version without Java, what Java have you installed on the server?

Also, when you run it with a launcher, you have to run it via Run as administrator.

I try to installed on other type setup with Java included x64 then I am happy because https is working.
Thank you for help.

hello @Lubomir_Hykl … Excuse me… i’ve the same problem , with openfire on https … Please can you tell me this alternative setup with java included x64 used by you?? can you give me a link?? thanks in advanced for your support…

I have ubuntu server 16.04 with openfire 4.3.2 and Java Version 11. At first it worked fine. But now I can’t access with any client anymore. Even access to console with localhost:9091 5 is not possible anymore. How can I fix that? Installation of openfire i do always with double click on ubuntu 16.04 gtk surface. A restart of openfire wasn’t enough. Complete restart of server solved the problem. Everthing is working fine now with ofenfire and OpenJDK: 1.8.0_191 Oracle Corporation – OpenJDK 64-Bit Server VM. Thanks for help! …

Good to hear that you’ve been able to work around the problem. Without knowing what the cause of your issue was, it is not feasible to tell you how to fix or prevent it. If it happens again, please look at the log files, to see if they hold any clue.

Openfire 4.3.2 is three years old. Ubuntu 16.04 is almost six years old. I recommend updating both.

sure, i’m going to update it soon.. .