powered by Jive Software

Openfire 4.3.2 remove idle connection setting not working properly

in Openfire 4.3.2 admin panel I have changed the client connection setting like disconnect the client after they have been idle for 10sec but it’s disconnection the client connection after 10 minutes and I have checked the system property xmpp.client.idle it’s 10000 milliseconds
I don’t know why

Edited
I think 10 minutes time limit is default time limit to remove to remove idle user even if I set it to 1 sec it’s removing after 10 minutes
Any suggestion how I can fix this from admin panel

As far as I can see, the default is 6 minutes - not 10. If you see a disconnect after 10 minutes, something else might cuase that.

The change to the xmpp.client.idle property will only apply to connections that were established after the change was made.

Note that ‘idle’ means: absolutely no data is being received from the client (which includes errors and whitespace pings). Openfire will automatically try to determine if the client is still alive by sending it a ping, when it has been silent for 50% of the idle time. If the client responds, it’s no longer considered idle.

By default. It can be over-ridden using Server -> Server Settings -> Client Connections and selecting the “Do not send XMPP Ping requests to idle clients.”. Probably not recommended, though.

Already did this but same result
even I closed my android app and remove internet connection but the result is same.
In Openfire 4.2.3 everything working fine but in new build i am getting this issue

In Openfire 4.3 Stream Management is working, which is designed to not drop connections after a temporary disconnect (your phone might have bad connection and this will make it reconnect every minute, but with Stream Management its connection is kept alive for it to quickly come back when network is up again). If you want, you can disable SM. Add system property: stream.management.active and value false.

Btw, when this happens you can see a client online on the users list, but his session should disappear from the Sessions page. That’s SM working.

You can also instead control SM timeout with xmpp.session.detach.timeout in milliseconds property (default is 10 minutes that you see).

2 Likes

Thanks @wroot it’s working :slight_smile: :slight_smile: :slight_smile:

Same issue happen in 4.4.1, but thanks for @wroot solution, its works for me.