powered by Jive Software

Openfire 4.4 to Mysql 8.015

Doing the initial setup of Openfire 4.4, I’ve completed the setup of the MySQL (8.0.15) DB but can’t get Openfire setup to connect to MySQL. I’d previously verified Openfire functionality using the embedded DB.

The stderror.log carps about setting useSSL=false in the JDBC connection string, so I’ve done that with no luck. Here’s what connection string now looks like:

jdbc:mysql://mysql8.xyz.com:6446/JABBER?rewriteBatchedStatements=true&characterEncoding=utf8mb4&characterSetResults=utf8mb4&useSSL=false

Java version is 1.8.0

Also verified that non-SSL connections are allowed using the --ssl-mode=disabled from the command line and it works.

Here’s the status from the command line connection.

mysql> status

mysql Ver 8.0.15 for solaris11 on x86_64 (MySQL Community Server - GPL)

Connection id: 475624
Current database: JABBER
Current user: Jabber@mysql8.xyz.com
SSL: Not in use
Current pager: stdout
Using outfile: ‘’
Using delimiter: ;
Server version: 8.0.15 MySQL Community Server - GPL
Protocol version: 10
Connection: mysql8.xyz.com via TCP/IP
Server characterset: utf8mb4
Db characterset: utf8mb4
Client characterset: utf8mb4
Conn. characterset: utf8mb4
TCP port: 6446
Uptime: 31 days 18 hours 43 min 49 sec

Can anyone point me in right direction.

I’ve managed to fix my problem after looking at the stdoutt.log (not stderror.log) seems the JDBC driver is rather picky about timezone settings.

Here’ what my JDBC connection string looks like now:

jdbc:mysql://mysql8.xyz.com:6446/JABBER?rewriteBatchedStatements=true&characterEncoding=utf-8&characterSetResults=utf-8&requireSSL=false&useSSL=false&serverTimezone=MST7MDT

FWIW, this Openfire instance is connected to a MySQL8 InnoDB cluster via mysql-router. I may even try switching the JDBC driver to use SSL in the future, but for now this works for me.

Hope this helps someone.

This is a widely encountered issue with the latest Openfire versions and new mysql connector.