powered by Jive Software

Openfire 4.5.2 support OS 2016 and SQL 2016?

I want to ask

if i upgrade Operation System 2016 and SQL 2016 does Openfire 4.5.2 work?

currently the openfire environment 3.9.3 and operating system 2008 and SQL 2008
clien Spark 2.7.0

Please advise

thanks

In theory it should be OK. That is a large jump with Openfire though. Will you be changing from 32 to 64 bit as well? That can be trouble on windows with the installer not properly updating the system between architectures.

As always, you should have tested backups ready to go in case something fails.

My servers are running on Server 2016, although I use MySQL instead of MSSQL. I personally despise MSSQL. Personal preference. Though I don’t see why it wouldn’t work. Like Akrherz stated, make backups. Are you using LDAP for authentication and your user lists? If so, why not just do a clean setup.
maybe you can export, convert and import your current database into the new engine and then do a clean install of OpenFire and point it to the imported database.
I did something similar when I moved our OpenFire server to a new host machine. I just exported the database from MySQL on the old machine, copied it over to the new one and imported it into the MySQL instance on the new machine. Then did a clean install of OpenFire and during setup pointed it to the imported database. Everything worked like a champ. All said and done, took about 5 minutes to complete.