powered by Jive Software

Openfire 4.6.0 is released

The Ignite Realtime Community is elated to be able to announce the release of Openfire version 4.6.0!

This release is the first non-patch release in 10 months, which brings a healthy amount of new features, as well as bug fixes.

I’d like to explicitly thank the many people in the community that have supported this release: not only were a significant amount of code contributions provided, the feedback that we get in our chatroom and on our community forums is of great value to us!

Highlights of this release include extensively improved XMPP protocol support, particularly around Pubsub and PEP and better compatibility with higher-end encryption parameters out-of-the-box, which should particularly benefit environments that make heavy use of server-to-server federation.

This release includes experimental support for federated multi-user chat for constrained environments (as defined in XEP-0289). This feature aims to reduce the dependency on highly reliable, high volume network connectivity.

The complete changelog contains approximately 80 issues that have been resolved in this release.

We invite you to give this release a try. The process of upgrading from an earlier version is as lightweight as ever. It is outlined in the Openfire upgrade guide. Please note that, if desired, a significant amount of professional partners is available that can provide commercial support for upgrading, customization, or other services.

We’re always happy to hear about your experiences, good or bad! Please consider dropping a note in the community forums or hang out with us in our web support groupchat.

You can find Openfire release artifacts on the download page. These are the the applicable sha1sums:

3747eb30a9c301cb4e169ea58682bffaec928d45  openfire-4.6.0-1.i686.rpm
446dd40b68e89311f4e7de62af4cb1dfe44cff2d  openfire-4.6.0-1.noarch.rpm
74023de1be0211bbc6879173bc9a5875605cd375  openfire-4.6.0-1.x86_64.rpm
0db33511ff833dc904ea7845d6eb3294cf418782  openfire_4.6.0_all.deb
fe7684d7ddf12896d138af64adb2d79f62874c29  openfire_4_6_0_bundledJRE.exe
cb490c5762c2f2f4ccd70a5a09b5faab59dc5e99  openfire_4_6_0_bundledJRE_x64.exe
fb915d112f522860fdd419c8bc0371f7a4a2105a  openfire_4_6_0.dmg
a5fada882ace449df9056205618e86312a08ec6e  openfire_4_6_0.exe
43a5b890e52b4baa7e8096410a7b398c89ad4d33  openfire_4_6_0.tar.gz
d11cfed06901fef69fcac1c3c4e28f60256baf62  openfire_4_6_0_x64.exe
86e150c2cb9b74c63b3907e3c036cc046c78c5ba  openfire_4_6_0.zip
436f9833fe8d7185c800daf3d35c2d5d11d1f6ea  openfire_src_4_6_0.tar.gz
a3a274b2f12d4cf9f15cb981e6c2b18c78ca07c6  openfire_src_4_6_0.zip

As per usual, we have created a 4.6 branch in our source code repository, that will hold follow-up bug fixes for this release, which will be numbered with 4.6.x identifiers. The main branch will over time evolve into release 4.7. We do not expect to perform more releases on the 4.5 branch.

Thank you for using Openfire!

For other release announcements and news follow us on Twitter

5 Likes

5 posts were split to a new topic: Cant enter to any conference room on Spark 2.9.2 after update OpenFire to 4.6

2 posts were split to a new topic: Plugins shows empty window in Admin Console with Openfire 4.6.0