Openfire 4.7.5 to 4.8.1 loading admin plugin failed with exception

Hi, i did the migration from 4.7.5 to 4.8.1, copied back the folders conf, embedded-db, plugins and resources/security, but when i started the openfire service again, i get the following log:
Version 4.7.5 in log seems strange to me, but the real problem is the Error with the admin plugin.
Hope you can help me out with this:

start.log (6,3 KB)

Did you copy all of the plugins folder? Then that’s probably the cause of this problem. You will have overwritten the admin directory that is in that folder.

Try copying only the .jar files that exist in that folder from the old installation to the new installation.

In my backup, there is no admin.jar, what i have is search.jar and sip.jar.

In the meantime i recursively copied the admin directory from my backup to the 4.8.1/plugins, but still no luck
Or, did you mean i must not copy anything from the old admin directory to the new one?

You must use the plugins directory as it comes with the fresh installation of Openfire, and only copy the .jar files that you had in your old install into it.

Crucially, do not modify the plugins/admin folder that exists in your new instance.

There is no admin.jar file. There’s only an admin directory.

Thanks, i tried that, but no luck. I think it has sth. went wrong cause there is still Version 4.7.5 mentioned while starting up:
start_new.log (1,7 KB)

What i did according to the upgrade_guide:

  • stopped openfire service
  • backuped the whole /opt/openfire
  • downloaded the 4.8.1.tar.gz
  • deleted everything in /opt/openfire
  • extracted 4.8.1 to /opt/openfire
  • copied conf- embedded-db- resources/security folder and the plugins/sip.jar and plugins/search.jar from my backup to the fresh /opt/openfire folder
  • started openfire service

xmpp works fine, admin plugin is not loaded due to NoSuchMethodError

The steps that you’re listing appear to be correct. Yet, the logs that you provide indicate that something else has happened. I’m not sure where things have gone wrong, but somewhere, they have.

INFO [main]: org.jivesoftware.openfire.XMPPServer - Openfire 4.7.5 [Mar 12, 2024, 2:46:02 PM]

This is a statement that is based in code, not configuration. This means that whatever logged this used at least libraries from the old instance.

This suggests that the state of the server that’s running is different from what you expect it to be. Maybe the old instance was not completely removed at all, and the extract of the new Openfire tarball caused binaries to be mixed with data from the old install? Maybe Openfire is starting from a completely different directory?

thanks guus, i will have a look at this and will let you know.

got it, thank you so much, of course “mixed” was the key.
On this machine, openfire was installed via .deb file and via tarball, so configuration files where mixed with symlinks pointing to other directories etc.
Uninstalling the .deb and extracting a fresh 4.8.1 tarball made my backup run in the end.

Can be closed, best regards

1 Like