powered by Jive Software

Openfire admin user not working with default password

Hello, I am new to open fire, I just downloaded and installed the openfire, setup the database, now on the admin account page, when I enter the default admin password it wont work

I check the database the users table is also empty. I am attaching screenshots with this post

Could you please verify which database you are using?

I am Using Mysql.DB tables are created but User Entry not created in DB.

There is something wrong with the SQL database scripts which initiates the Openfire databases. Try to download the fixed installer from here: https://community.igniterealtime.org/blogs/ignite/2016/12/21/openfire-410-final- release#comment-11792

https://bamboo.igniterealtime.org/artifact/OPENFIRE-NIGHTLYWINDOWS1/shared/build -3/Project-Windows-distribution-files/op…
Page not found error

This is a bug that was fixed in Openfire 4.1.1. Please download Openfire 4.1.1 or later, and you should no longer have this problem.

1 Like

Noman,

No need to download bamboo builds, Openfire 4.1.1 is released now.

Openfire 4.1.1 work fine.

hello,I have same problem,Have you solved? Openfire 4.1.1

Yes v- 4.1.1 solve this.

but I have same problem,I download is openfire - 4.4.1-1. X86_64. rpm,The default password is ‘admin’,but always prompt ‘Please enter the correct current password.’,I check the database the ofuser table is also empty.Is the first time installation.I tried many times,but the result is still the same.

If you want to fresh install.remove all old openfire components.like** db,openfire and physical files**.

for remove openfire use

sudo apt-get purge openfire

and then install from start latest version of openfire.

I’m using last version v 4.3.2 on orangePI Plus 2E with Debian GNU/Linux 9 (stretch)
Linux orangepiplus2e 4.19.20-sunxi #5.75 SMP Sat Feb 9 19:02:47 CET 2019 armv7l GNU/Linux

root@orangepiplus2e:~# dpkg -l|grep maria
ii  libmariadbclient-dev                   10.1.37-0+deb9u1                                                   armhf        MariaDB database development files
ii  libmariadbclient-dev-compat:armhf      10.1.37-0+deb9u1                                                   armhf        MariaDB database development files (libmysqlclient compatibility)
ii  libmariadbclient18:armhf               10.1.37-0+deb9u1                                                   armhf        MariaDB database client library
ii  mariadb-client-10.1                    10.1.37-0+deb9u1                                                   armhf        MariaDB database client binaries
ii  mariadb-client-core-10.1               10.1.37-0+deb9u1                                                   armhf        MariaDB database core client binaries
ii  mariadb-common                         10.1.37-0+deb9u1                                                   all          MariaDB common metapackage
ii  mariadb-server-10.1                    10.1.37-0+deb9u1                                                   armhf        MariaDB database server binaries
ii  mariadb-server-core-10.1               10.1.37-0+deb9u1                                                   armhf        MariaDB database core server files
root@orangepiplus2e:~# dpkg -l|grep mysq
ii  default-libmysqlclient-dev:armhf       1.0.2                                                              armhf        MySQL database development files (metapackage)
ii  default-mysql-server                   1.0.2                                                              all          MySQL database server binaries and system database setup (metapackage)
ii  libmariadbclient-dev-compat:armhf      10.1.37-0+deb9u1                                                   armhf        MariaDB database development files (libmysqlclient compatibility)
ii  mysql-common                           5.8+1.0.2                                                          all          MySQL database common files, e.g. /etc/mysql/my.cnf
ii  mysql-server                           5.5.9999+default                                                   armhf        MySQL database server binaries and system database setup [transitional]
root@orangepiplus2e:~# 

I have exactly the same problem as the “W_C_L” user have.
I reach the point when I need to definate the email address and password and Openfire asking from me to enter a current password (what it need to be an admin, but it always giving me an error:

Please enter the correct current password. 

The database is good what I made or openfire and it looks toaly same as from user “W_C_L”.
Interesting is that on Debian v8 with kernel v3.4.xxx I have not this problem (on arm platform).
Deb 9 replace Mysql database with Mariadb, and here can be the problem with comunication.
I changed the bind-address in both of file:

/etc/mysql/mariadb.cnf
/etc/mysql/my.cnf

but still nothing.
If I omit that step where it asking me to change the password I can finish setup but it is imposible to login through webinterface.
The install is clear of OS and openfire too!
Is there any chance to definate some password in database?
How can I solve this problem?
Thx

If somebody new gets here, I have the same problem with the Openfire installation file version 4.5.1 x64 in Windows 7 x64, but the 32 bit version works perfect, of course You have got to have the Java JDK 32 bits version installed.

P.S. Here You can find the 32 bits version: https://github.com/igniterealtime/Openfire/releases