powered by Jive Software

Openfire always presents Login-Box even though login was successful

  • We installed Openfire on a Suse 10 and started it with via “openfire start”

  • The login-screen is presented.

  • If I enter a wrong password I am redirected to login.jsp again and get the error-message (fine!)

  • If I enter the **right **password I am redirected to *login.jsp?url=%2Findex.jsp *but still the login-box (without any error) appears.

I read all applicable messages in the forum but none of them would give me a clue. I even looked at the index.jsp but the only thing that would redirect in the jsp would be to logout.jsp. I see no area the prevents the actual main screen instead the login-box to be shown. As it is hardly impossible to modify the jsp or anything else because everything is in the pack-files I am not able to debug something or add log-information. I even added “debug” information through the openfire.xml but it does not mention anything abnormal.

To me it looks like a login-cookie or -information is not set accordingly during login and when the index.jsp is shown it lacks the information and “goes back” to the login-box.

Any help is greatly appreciated as we already investigated many hours on this issue.

TIA

Stefan

Hi Stefan,

so I assume that you did restart Openfire already a few times without success. I’d say that you can use an XMPP client and login fine using your admin account.

You may want to execute “INSERT INTO OFPROPERTY VALUES(‘admin.authorizedJIDs’,‘admin@your-xmpp-domain’)” within your database or try to add admin@your-xmpp-domain to your openfire.xml file.

LG

what a pity, still no success. I actually think that the authentication does work. Your idea would “just” make it “even more” work. To me it seems that the authentication happens but still the index.jsp will not show up - instead the login-box does. Note that the url is login.jsp?url=%2Findex.jsp and not login.jsp. The first happens when I enter the right information, the latter when I login with incorrect data.

cheers

Stefan

I found the reason: It is definitely a bug in 2.6.4!!!

  • I deleted the whole installation, re-installed 2.6.4 and I still had the problem

  • I deleted the whole 2.6.4 installation, downloaded 2.6.3, installed it and it works now!

**NEXT ISSUE: **

I can’t run in on port 9090, so I do a reverse proxy but due to the implementation of the JSPs that includes all resources (jsps, css, img…) to / ( ie. the URLs all start with a slash), I cannot proxy it to http://myserver/openfireurl/… with the apache!

Is there an easy way to fix the jsp and compile it into the jsp-class-files because unfortunately all jsp are not delivered as JSPs but as compiled class files. Or would it be even possible to just put the JSP somewhere instead the class file of it?

Where can I open bugs for the current issue and a feature request for either changing the URLs in the JSPs or adding a -tag to the pages, which should do the trick pretty easily?