powered by Jive Software

Openfire and converse.js

I have been installing openfire today and managed to connect ‘pidging’ IM to openfire. Works like a charm.

After this I continued on my awesome plan to connect ´converse.js´ jquery chat library for website chat.

However it keeps ‘hanging’ after connecting. I checked the logs of openfire and found that I am getting SSL handshake errors. (unknown_certificate).

After the first problem I have tried 2 different javascript based xmpp implementations but both will result in the same error within the logfiles.

I did indeed need to accept the security certificate when I connected with pidgin IM-client.

I have googled a bit and put some settings different then default install, which has not resolved the issue as of yet.

I am using the latest version

I have changed: client security to all Optional

I have changed: Scripting allowed for BOSH clients.

Is there a fix for this or do I need a fully-signed certificate?

Any pointers that might steer me in some possible direction are greatly appreciated.

I managed to find out what was the problem. It was my own fault.

I used a BOSH servlet in java to connect trough to the xmpp service of openfire. Which one was quite old. Using strophe I managed to debug and figured this was the offender.

Removing all that and testing converse.js by putting the example html+js in the resource/spank (to avoid CORS issues) folder of openfire it all worked nicely.