Openfire and Java Memory [WinXP]


Sorry 4 Englisch, Iam german, i can read english good, but write xD.

Ok…i have downloaded the Openfire Version for Win XP.

Installed at a Win Xp Prof. Client.

Configurate…and it Works.

But the Java Memory has 12,05 MB of 63,31 MB (19,0%) used

a little bit small.

I Search at google and so on but i dont find a answer for the XP Version, Only for Linux i found help, but i dont use linux.

Have anyone a Idea how i can change the Java memory?!I need a little bit more .


Try this link it worked for me. I am using Openfire 3.6.0a.

I am going to give you more information than you asked for. First configure openfire to run as a service:

If you’re running Openfire on Windows, you will likely want to run Openfire as a standard Windows service after initial setup. If you used the Windows installer, a openfire-service.exe file will be in the bin directory of the installation. You can use this executable to install and control the Openfire service.

From a console window, you can run the following commands:

  • openfire-service /install – installs the service.
  • openfire-service /uninstall – uninstalls the service.
  • openfire-service /start – starts the service
  • openfire-service /stop – stops the service.

After this create the file that will adjust the memory for java:

Advanced users may wish to pass in parameters to the Java virtual machine (VM) to customize the runtime environment of Openfire. You can do this by creating vmoptions files in the bin/ directory of your Openfire installation. For the Windows service, you’d create a new text file called openfire-service.vmoptions. Each parameter to the VM should be on a new line of the file. For example, to set the minimum heap size to 512 MB and max VM heap size to 1024 MB, you’d use:


To create parameters for the normal launcher, create a file called openfired.vmoptions (since the openfire.exe launcher invokes the openfired.exe executable to actually start the server).

I use a window opensource program called notepad ++ to create/edit all settings files for openfire.


yeah it works…but…i have created ah: openfire-service.vmoptions with -> -Xmx1024m

i copty that in my openfire\bin folder…when i start openfire only…it dosnt work, when i start the service, and then the openfire console i see the 1024m…but i become many errors in the console.

Stop Service -> start openfire console…no errors and no 1024m.

Part of the error.log:

at org.jivesoftware.openfire.XMPPServer.verifyDataSource(
at org.jivesoftware.openfire.XMPPServer.start(
at org.jivesoftware.openfire.XMPPServer.(
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance0(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at org.jivesoftware.openfire.starter.ServerStarter.start(
at org.jivesoftware.openfire.starter.ServerStarter.main(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)
at com.exe4j.runtime.WinLauncher.main(Unknown Source)
Caused by: java.sql.SQLException: ConnectionManager.getConnection() failed to obtain a connection after 11 retries. The exception from the last attempt is as follows: java.sql.SQLException: The database is already in use by another process: org.hsqldb.persist.NIOLockFile@9f736229[file =C:\Programme\Openfire\embedded-db\openfire.lck, exists=true, locked=false, valid=false, fl =null]: java.lang.Exception: Der Prozess kann nicht auf die Datei zugreifen, da ein anderer Prozess einen Teil der Datei gesperrt hat : C:\Programme\Openfire\embedded-db\openfire.lck
at org.jivesoftware.database.DbConnectionManager.getConnection(DbConnectionManager .java:124)
at org.jivesoftware.openfire.XMPPServer.verifyDataSource(
… 16 more”

Hi Rhuen,

" The database is already in use by another process:" means that Openfire is still running. Look for java processes in the task manager and try to kill them or reboot your computer.


Hmmm wenn i stop the service openfire, and then i start openfire i had no errors.

Only the service is running, and then i will start openfire i become this errors.

I read anyone what about this…how must i openfire start when the service is running?! over the openfire.exe isnt good standing here.

Over the cmd console?!

I think that i start openfire wrong when the service is running, and then comes the error.

Ok, it works.

Iam a idiot xD.

openfire-service -start…than its ready and i can log in…i have klick openfire-service -start and then i open die openfire.exe and start openfire again -> errors .

Now it works…only start over cmd -> the openfire-service and its run.

Don’t forget to award points for correct/helpful answers.