powered by Jive Software

Openfire (and Spark) and Java


#1

Not being a Java person at all, I have a quick question: For the installs of openfire (and spark) bundled with java, should I be concerned with using openfire and Oracle’s new licensing mandate?
My current Openfire server is running v4.2.3 and I would like to upgrade to v4.3.1 using the installer bundled with java. Or am I just being a worry-wart?

Thanks


#2

Openfire and Spark currently use Java 8. Licensing changes affect 10-11 and later Oracle’s Java versions. Although this is not clear what this mean exactly for software like Openfire/Spark. I would say you are safe for now with currently bundled Java 8. It is not clear when (and whether) Java 10+ support will be introduced.
https://issues.igniterealtime.org/browse/SPARK-2017
https://issues.igniterealtime.org/browse/OF-1383