powered by Jive Software

OpenFire and Tomcat

I’‘m looking to run OpenFire on my server, but I’'m not sure if I can… The way I undestand it is that OpenFire runs in its own Java EE server - but I already have Apache Tomcat 6 installed and running on this same server.

Would there be a conflict in the ports or the configuration if I ran OpenFire on a server with Tomcat installed? Is there a workaround? Better yet, can I run OpenFire under my existing TomCat install?

Thanks.

Hi,

Openfire uses afaik port 8080 and 8443 for HTTP Binding. It is possible to configure other ports in Openfire or you could change the Tomcat configuration. Openfire uses Jetty only for it’'s servlets (the web admin gui).

There were some problems with a wildfire.war build which could run in Tomcat so the .war release is no longer available.

LG

Thanks, but there is a little twist that seems to be a bug:

EVEN IF HTTP Binding is set to “disabled” OpenFire will attempt to bind to those ports that are already in use by Tomcat, and when it fails, no XMPP funcitonality will be availabel.

Fix: turn off tomcat, enable http binding, change the ports, save, disable http binding, then start tomcat.

Hi,

you’'re the 2nd user who complains about this. For me it works fine to disable these ports while Openfire is running.

Does this happen during startup that Openfire tries to open these ports?

LG

This happens to us as well. We’'re going to try turning binding on to a different port, then disabling binding and see if it still tries to grab the default ports. Very annoying that it does that…

-Alex

Are there any exceptions in the logs when you attempt to disable it?

Thanks,

Alex

Well, it’'s disabled by default.

While it’‘s disabled, the error log shows that OpenFire still tries to bind those ports, then there’‘s an exception when it can’‘t because they’'re already in use.

For what this is worth, I had the same problem with port the openfire server binding port 8080.

I logged into the openfire admin console, and selected to enable http binding. I then changed the port to some other number (i.e.: 8181). Update your settings, then disable the http and click update one more time. No more binding competing. Hope this helps.