powered by Jive Software

Openfire as xmpp server in jitsi meet

Hi there
I want use openfire as a xmpp server instead of prosody in jitsi meet.

I create account for focus and jvb and also define focus and jitsi-videobridge as external components in admin web console.

but in openfire log, I see the following log:

INFO [socket_c2s-thread-3]: org.jivesoftware.openfire.spi.RoutingTableImpl - Will not route: Remote domain internal.auth.mydomain.com is not accessible according to our configuration (typical causes: server federation is disabled, or domain is blacklisted).

I also asked in jitsi forum in this topic

and my question was answered:

You need to create that muc component in openfire.

But I think that I create the muc component in openfire.

Where is my problem?

Thanks

Getting Jitsi Meet to work with another XMPP server than the one that they’re using is hard. They have not made a solution that aims to be portable. It is possible, however: we have the ofmeet plugin that does exactly that.

The error message seems to indicate that you need a conference service called ‘internal’. You can check if you have one, by going to the admin console, and navigate to the summary of all conference services: Group Chat > Group Chat Settings > Service Summary

The default conference services that I expect to be there is called ‘conference’. You will need to create another one, called ‘internal’ to work around the particular error that you show.

I do not know (but I suspect not) if this is the only issue that stands between you and a functional integration. As I said, this gets tricky, fast.

1 Like

Thanks @guss

yes, and I remove auth after internal and before mydomain.com in jitsi-meet (jicofo and videobridge) configs.

all things seem be correct.