powered by Jive Software

Openfire behind apache and proxypass

We would like to run the openfire software behind apache using the proxypass module so that we can use modsecurity

We will not be using webspark, just the spark client.

We currently have proxypass configured to direct all http://oursite/chat forward to htp://oursite:9090/webchat

it’s connecting fine but from there, it tries rendering links and images using :9090 and not following the proxypass rules.

ProxyPass /webchat http://172.16.1.1:9090/webchat

ProxyPassReverse /webchat http://172.16.1.1:9090/webchat

ProxyPass /adminlogin http://172.16.1.1:9090

ProxyPassReverse /adminlogin http://172.16.1.1:9090

Those are our current rules.

-D

before corrections are made, the first link was meant to be typed as http://oursite/webchat … just a typo in the post, not our config.

NameVirtualHost *

<VirtualHost *>

ServerAdmin webmaster@localhost

DocumentRoot /var/www/

<Directory />

Options FollowSymLinks

AllowOverride None

</Directory>

<Directory /var/www/>

Options Indexes FollowSymLinks MultiViews

AllowOverride None

Order allow,deny

Allow from all

</Directory>

    ProxyPass / http://192.168.100.1:9090/

<Location />

      ProxyPassReverse http://192.168.100.1:9090/

      ProxyHTMLURLMap http://192.168.100.1/ /

</Location>

</VirtualHost>

~

Solved: just place the above in your default apache conf and everythng should be well.

We were trying to seperate the admin login and the webchat login, but by proxy’ing / all together, it fixed the issue.

Now you should be able to run modsecurty as your frontline firewall.

-D

I couldn’t make it work like is explained here. Insted i’ve got to put this on my virtual host

ProxyPreserveHost On

ProxyPass /webchat/ http://localhost:9090/webchat/

ProxyPassReverse /webchat/ http://127.0.0.1:9090/webchat/

I need some help

I only have one port available on the client side, port 1234 (firewall)

I am running Open Fire on a server which is using DDNS

Because I can only use 1 port on the client side I run everyting behind Apache as much as possible on the server

This includes svn, eventum, applications etc, everything goes through port 1234 and Apache does the rest

I would also like to run Open Fire behind Apache

So the Spark client would use www.mydomain.com:1234

and Apache would route this to port 5222 (the Open Fire chat port) on the server side

Does anyone have a simple explanation on how to do this ?

Your help would be much appreciated

Hi,

you should be able to get a web based chat running behind Apache without problems.

XMPP is a completely different protocol, so it’s not possible to use Apache as a proxy for it.

LG

I dont see anywhere in your last settings that setup the webchat path.

Its all about the admin login. So what do you do with the webchat?

Im having problem with the webchat because it kept redirecting to the port:8080 when accessed externally.

Please help.