powered by Jive Software

Openfire Chat API


#41

I am using Openfire 4.2.3, When I upload the plugin, I get an exception like this


#42

Try latest version 0.9.4 Release 7.


#43

Thanks for quick respones @Dele_Olajide. I am getting same exception with the latest release as well.


#44

That’s interesting. Never had that before. Maybe it has a dependency on another plugin. What other plugins do you have installed so I can replicate your environment?


#45

I had REST API plugin installed earlier, but I uninstalled it and then I installed chat api plugin.
Sharing screenshot of all installed plugin,


#46

Nope. I can’t reproduce your issue. I notice you are running version 0.9.4 Release 4. I am running latest version 0.9.4 Release 7


#47

I have tried using release 7 as well and tried with other openfire server as well. Same issue.


#48

Sorry. If can’t reproduce the issue, there is not much I can do to help you


#49

I was able to run it via embedded database but not with standard database.


#50

Hi. Could you tell me what is in the “userId” parameter for the upload request? I have tried everything and it always throws me Response Code 400.

The HTTP File Upload plugin is installed and from the plugin ofchat I am using the version Etherlynk-Server-0.9.3-release8 which is located here https://github.com/Traderlynk/Etherlynk-Server

Any help or example is appreciated.


#51

Use the latest Openfire Chat API which now lives at https://github.com/igniterealtime/Openfire-Chat. Project Etherlynk is no more maintained.

The userId parameter is any valid openfire username


#52

Thank you for the feedback


#53

Thanks for your answer, I did not want to change to that version because it does not allow me to enter the Swagger section to make the consultations via web.

I tried the latest version in Postman and it worked for me, only that port 7443 would throw me error even disabling SSL validation as Postman indicated.

Then I had to use the 7070 where “localhost” appears instead of the server ip, which I do not know if it’s normal or if it’s due to using another port

Finally when trying to upload the file I get “400 The requested slot is not available. Either it does not exist, or has already been used” :frowning:

As header I only have “Authorization”.


#54

Look at https://github.com/igniterealtime/openfire-httpFileUpload-plugin/blob/1f3bad84b898869e3d6d510db6331e6a539e6b1a/src/java/org/igniterealtime/openfire/plugins/httpfileupload/HttpFileUploadPlugin.java#L55

The httpfileupload plugin for openfire is hard-wired to use https and the hostname of your openfire server. You really have no choice but to get a proper certificate and make sure your openfire server hostname is NOT localhost


#55

Thanks, seems to work. But I’ll have to find another way to test it since with Postman I get problems due to the size of the file that I define before


#56

Just in case it is the max file size, see https://igniterealtime.org/projects/openfire/plugins/1.1.0/httpFileUpload/readme.html


#57

Excuse me but where is that option? I’ve searched everywhere and I have not found it. :frowning:


#58

You have to create it yourself if it is not visible (in System Properties).


#59

Thanks for answering. Add the option and leave the maximum file size disabled by setting the -1

I tried to upload this file again

image

through postman:

but again I get the same error. I also tried increasing the file size to 226080 in the request, but it gives me the same error :frowning:

Now restart the server after adding that property and also try calling the file photo.jpg. Still not working